[Bug report] Ratchet Gladiator - freezing after 1st teleporter [Resolved]
I'm playing the PAL version of Ratchet Deadlocked (aka Gladiator), iso file being ripped from disc, and whenever I get to the first teleporter after the initial "moving around" tutorial, the game freezes. I get no error reports in the log, the game just doesn't continue but shows a black screen. I've tested it with two SVN revisions, one fairly new (r4182) and one older (4072).

On the newer revision the sound keeps playing like normal after going through the teleporter, as if the cutscene was running, but stops after that. On the older one, I only hear the ambient sound, other than that there's no difference. Haven't tried it with the public beta yet though, but I think the 4072 at least should be pretty compatible as it works with anything else I've tried. I haven't had any problems with the other Ratchet & Clanks either.

Also, if I don't use speedhacks to run the game, the game (and the emulator) will "freeze" or rather, stop responding already in the first ingame scene of the raft carrier flying to the dreadzone containment zone. I can see the windows loading cursor flicker for a while and then the emulator just stops responding, with the log printing "TLB miss" error message endlessly on both revisions, and I have to use task manager to kill pcsx2.

I also tried dropping speedhacks one by one (starting with the block hack and vu min/max hacks) but haven't found a working solution yet. I kind of doubt they might cause it, since Ratchet & Clank 3 works with nearly every single speedhack (save for maximum vu steal) enabled without any problems, and Gladiator uses the same engine for all I know.

Game itself works playably from the little I managed to test, a few fps drops though but it's manageable.

System & plugin specs:

- Intel Core 2 Duo T6600 2.2 Ghz
- 4 GB RAM
- Ati Mobility Radeon HD 4670 XT 1 GB
- Windows 7 Home Premium 64 bit

Gsdx SSE41, Direct3D10 hardware mode, 1920x1080 internal res, texture filtering enabled
SPU2-X, 2x reverb, 5.1 audio enabled

Speedhacks in use so far: Everything except vu cycle steal at medium and no "fast cd/dvd" hack

EDIT: Tried without any vu cycle steal hack, still the same issue.

Sponsored links

Tried again with a newer revision (r4324) and the game gets past that point without issues now. Smile
Good to hear Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!

Users browsing this thread: 1 Guest(s)