Bugs on linuzappz CDVD iso DVD9 compression / decompression Z2 or BZ2
i'would like to report bugs on Linuzappz CDVD Iso Plugins.
First of all, i dont know that this is the correct place for reporting bugs on plugins, please pardon me if its wrong. And i don't know if this bugs has been reported or not, i tried to search the bugs in this forum but cannot find it. i like this plugins very much. i can store nearly 1.5x times using compression bz2 / z2 than the iso dump from the original DVD.
i read somewhere in this forum (using search tools) the author Linuzappz has gone somewhere no one can tell. i would like to know if this plugin is going to be developed further.

Anyway the bugs is compression on disc DVD9 version. i store nearly all my DVD to my storage so that i can play it fast using pcsx2 and compressed it using this plugins.
i usually play from the bz2 / z2 directly too, but somehow yesterday i get tired of playing RPG action and want to play racing stuff. i select GranTurismo4, like usual logos etc, but the FMV wont startup.
I'm wondering if my RAID setup is failed, but all my other files where intact and i just play Shadow Hearts just fine yesterday. It turns out that all my DVD5 are able to run, but the DVD9 version such as XenoSaga or GoW II were unable to play properly.
So i try to decompress it to see if there is errors and compare it to the original DVD.
here is the error:
_isoReadBlockBZ2 4114016, 2048
-947625864, 32752
error on BZ2: -5
block 4114017
block 4114018
_isoReadBlockBZ2 4114032, 2048
-947593112, 32930
error on BZ2: -5
block 4114033
and so on
so i redump the original DVD9 of GT4 and hex compare it ... and different only after 4.39GB of data
Z2: 4692586496 bytes or block 2291302
BZ2: 4725702656 bytes or block 2307472
and the pattern of differences is scrambled of existing bytes from 0 to 4.39GB (i search a random 48bytes hex values of different data on decompressed BZ2 on GT4)
so i thoughts this must be error when saving / compressing..., but when i compress again from the Original DVD9, the result of BZ2 compression is the same, and the decompressed iso is also contains the same error.
plugins version i tried: pcsx2 0.9.2 Linuzappz 0.5.0, pcsx2 1.0.0 r5628 linuzappz r5557
thank you.

Sponsored links

Users browsing this thread: 1 Guest(s)