CDVD Read Error - Katamari Damacy
Hey, I'm sure you guys get these all the time, but even after searching around, I have no idea how to fix this.

When I load up Katamari Damacy, the game will open up but then I get a black screen with the game's little loading star in the bottom right. That sounds good, because thats how it should start I think, but then the terminal gives me this error:

"CDVD READ ERROR, Sector = 0x0014830d"

Katamari will not move off the loading screen.

I am loading from an ISO I burned, and have tried re-burning multiple times to the same result.

Sponsored links

Either you're using your terminology in reverse (you burn an ISO onto DVDs, you "dump" or "read" a DVD to hard drive), or you are indeed burning an ISO to DVD and trying to play off of the DVD, which isn't a good idea on multiple levels.

As the error states, it's a read error... either the ISO is bad, or the disc is scratched/unreadable. Create a new ISO file using imgburn (google it, free app) and try again. Make sure "skip errors" isn't checked.
[Image: 2748844.png]
Yea sorry, I guess burn is the wrong word. I used Imgburn to make a new ISO multiple times and they always give me this same result.

Edit: I opened ICO to see if maybe a totally different ISO would work, and it does.
I have recently been getting into emulators myself. I have beaten Katamari Damacy so many times. I popped the disk in after setting up the emulator and I got the same thing.(CDVD READ ERROR, sector = 0x0014830d) Any ideas?

Users browsing this thread: 1 Guest(s)