Can't Use Opengl since the latest changes
I am trying to use any ps2 game with opengl on the very latest version released on github. It tells me it failed to find gltexparameter and it does this on both hardware and software modes which is weird because i have a gigabyte gtx 960 and it worked on previous versions of gsdx with opengl. My hardware is AMD FX-8350 8 core, gigabyte gtx 960 2gb, 16gb crucial ram, using default settings on the emulator and cant run anything on opengl under native and up because of the reason typed above. It also worked on all versions of gsdx prior to this commit being done "gsdx-ogl: rework palette texture handling Redirect the red channel to alpha channel for 8 bits texture. It avoid special management in the shader." I hope all of this information helps a little.

Sponsored links

are you completely sure that his commit is broken while the previous commits work?

Can you compile/debug yourself? Do you get any stacktrace (maybe the file GLLoader.cpp is making this issue...?) information when it tells you 'it failed to find gltexparameter'?
Well it is possible. I got issue to make it work on linux. Can you post the gsdx error output.

Edit: please latest git it must work better
I'm not sure what the issue was earlier to cause it to tell me that gltexparameter did not exist but I just retried with latest everything again from github I downloaded it again as I saw it had a change again. The emu loads all games now using opengl hardware and software. Sorry all for creating annoyance. It was just a very strange occurence as I had never seen that before and it did not make sense and still don't but I thank you for your replies everyone and no I don't know how to compile for my self yet. I will post again if I happen to experience the bug again along with the gsdx error output should it come back. Thank you again you guys for checking back with me I appreciate the pcsx2 crew.
No worry it was a real bug on windows (my PC is on linux so I didn't see it earlier sorry for the inconvenience)

Users browsing this thread: 1 Guest(s)