Can't change GS settings.

My problem:
No matter which GSdx version I select (SSE2, SSE3, SSE41), I can not "save" any settings I change in the configure screen. I've used this emulator in the past on this same pc and I successfully used SSE41 in Direct3D10 hardware mode without any issues.

But now it's set to Direct3D9 hardware mode on default and whenever I change this to any other setting and close the screen by hitting "OK", it never applies those settings. I tried pressing "apply" and "OK" in the components settings screen too. I tried restarting pcsx2 after changing the settings, no matter what I do, it'll stay stuck on Direct3D9 hardware.

Every other plugin setting works: controller, sound, etc. Everything I change works and stays that way.

I tried googling this problem and I've also tried searching this forum. I've come across similar, but not exactly the same problems. But I still can't get it to do what I want it to do.

Note: I can play games and it all looks very nice. I just don't understand why I can't change the GS settings.

My setup:
I'm using pcsx2 version It's installed on my C harddrive (in program files) and my profile also has full rights for it (I'm the administrator).

My graphics card is a Ati Radeon 4870 1GB version and as I've mentioned earlier it had no problems running the Direct3D10 hardware version like a year ago.

My request:
I would really appreciate anyone helping me with my problem. Thanks for reading this.

Sponsored links

I assume you're under VIsta or 7
right click->Run as admin
and move pcsx2 folder out of program files. Put it in an admin rights-free folder (i.e: c:\pcsx2)
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Thanks for the response.

As I've stated in my op, I have full rights + I've tried running it as administrator already.

Just to be sure, I've moved the pcsx2 folder and all its contents to C: (not inside program files or any other folder) and then ran it by right clicking it and running it as admin, but the same issue still exists.

Edit: Yes I'm using Windows 7 x86 version.
does psx2 folder or plugins folder or both have read only attribute ?
and what about your inis folder ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Both the pcsx2 folder and the ini folder inside are not "read-only".
I've checked in their properties to make sure.

I appreciate your assistance, any other ideas?
Tried googling the problem in many different ways, but it almost seems as if I'm the only one that ever had such a problem.
It's indeed strange that you can setup the other plugins just fine.
No idea here either how that could happen..

Well, try to change the usermode via first time wizard so PCSX2 looks in
it's own directory for inis. Do that via Config > Clear all settings.
Next time PCSX2 starts up you get the wizard again.
Thanks for your response.

I've did what you've told me. I rerun the wizard. I've selected SSE41 out of the list and hit "configure" and strangely the configuration was automatically on Direct3D10 with the settings I've been trying to enable the whole time.

So I was glad, because I thought that it worked. I hit "ok" and then hit "next" on the wizard, picked my bios and finished the wizard.

I immediately went to "config -> video (GS) -> plugin settings" to check whether it was still on Direct3D10, but again it reverted back to Direct3D9. I changed all the settings again, pressed "ok" etc. Then re-opened it and again it reverted back to Direct3D9.

All the other plugin settings still work. Lillypad, SPU2 etc. No matter what I change there, it sticks.

This is SO weird.
Try deleting your inis folder and configure again.

Try uninstalling PCSX2 then reinstall to a folder like c:\pcsx2 and not the program files folder.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
I've tried deleting my inis folder, both from the pcsx2 folder where it was installed as from the folder in the users folder where it also saves memcard and bios information. That doesn't work.

The weird part is that in those inis folders I get .ini files for things like audio settings (SPU2-X), controllers (Lilypad), etc, but no .ini file is made for GS settings. No matter which GS plugin I choose. This is the same for both inis folders (the one where it's installed as the one in c:\users\etc).

I've also tried uninstalling everything completely and reinstalling it in just C:, installing it in C:\new folder and in a folder on the desktop. The same thing still happens.

I've tried all these steps together with me running the .exe as administrator and by making sure that no file or folder is "read-only".

This is so extremely weird that no matter what I do, the emulator refuses to acknowledge any configurations for the GS plugins.

Users browsing this thread: 1 Guest(s)