Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't figure it out
#1
I'm having issues with slow downs and frame rate dropping to the 20s-30s on Dirge of Cerberus (really early on in Kalm as soon as you come out of the alley). I haven't messed with any configurations outside of the presets. I've never seen the CPU peak above 60% on any core or the GPU above 40ish-50ish% at native resolution with the following specs:

CPU: Ryzen 5 3600
GPU: GTX 1660 (using open source 455.38 drivers Opengl is on 4.6.0) 
OS: Pop_OS 20.04 (Ubuntu variant)
PCSX2: stable 1.6.0 and nightly 1.7.0

I'm still trying to rip the rest of my games, but I did get DDR Extreme to work well. Any help would be appreciated. Nostalgia struck me hard and I wanted to play DoC, but my PS2 isn't spinning discs properly, so emulation is my only option.
Reply

Sponsored links

#2
Simply don't use NVIDIAs Opensource drivers, they're not suitable for 3D-Workloads, use the properitary if you need performance.
Tired of always changing your PCSX2 Configuration for different games?

Check this out: https://forums.pcsx2.net/Thread-PCSX2-MultiConfigTool
Reply
#3
I switched to the 450 proprietary drivers and its just as bad. I still have a huge performance drop in the same areas. I did enjoy FFXII and Dark Cloud 2 at 4k for about an hour each and never noticed a drop. I kept an eye on the system monitor and never noticed a core get above 80% usage with any of the games except for loading in new areas. I'll keep trying other games as I get them ripped, but I assume it's just something with Dirge of Cerberus? I noticed the video on the front page loads in after where I am having issues and they are only at 1440p 60fps and I'm assuming with a better rig than mine.
Reply
#4
Dirge hits hard in that section at the start of the game, it can be really bad during the last helicopter fight.

On Windows I use D3D11 and deal with some graphical issues to play that section because the perf is pretty bad.
On Linux where you only have OGL you can try sticking blending to none and seeing if it helps any, never tried myself. You can also try powering through it with the software renderer since your CPU is decent.

The good news is past that part I don't recall any performance issues. It's just that one section for whatever reason.
[Image: HkgHT5k.gif]
もっとちゃんと言ってよ
忘れないようメモにしてよ



Reply
#5
I tried the software render and that bumped it up a few fps, but not much different. Setting the blending to none definitely made it playable at the point. It still drops and isn't pretty, but only drops to about 45 fps as opposed to what I was getting before which dipped into the 20's. I'll progress a bit further now that I have some hope that it'll get better. Oh, and thank you XXXBold for the Multiconfig Tool it's already making switching stuff around a lot easier.
Reply
#6
yeah let us know
[Image: HkgHT5k.gif]
もっとちゃんと言ってよ
忘れないようメモにしてよ



Reply




Users browsing this thread: 3 Guest(s)