Can't install dependencies for compiling on Ubuntu 14.04
I've tried building PCSX2 from source because I have a feeling the one in the PPA is old, and a game I want to try isn't working properly.

Following the guide here i've ran:
sudo apt-get install libaio-dev:i386 libasound2-dev:i386 libbz2-dev:i386 libcg:i386 libcggl:i386 libegl1-mesa-dev:i386 libgl1-mesa-dev:i386 libglew-dev:i386 libglu1-mesa-dev:i386 libgtk2.0-dev:i386 libjpeg-dev:i386 libsdl1.2-dev:i386 libsoundtouch-dev:i386 libsparsehash-dev libwxbase2.8-dev:i386 libwxgtk2.8-dev:i386 libx11-dev:i386 nvidia-cg-dev:i386 nvidia-cg-toolkit portaudio19-dev:i386 zlib1g-dev:i386

Then I got the following message:
The following packages have unmet dependencies:
libgtk2.0-dev:i386 : Depends: gir1.2-gtk-2.0:i386 (= 2.24.23-0ubuntu1.1) but it is not going to be installed
                      Depends: libgdk-pixbuf2.0-dev:i386 (>= 2.21.0) but it is not going to be installed
                      Depends: libpango1.0-dev:i386 (>= 1.20) but it is not going to be installed
                      Depends: libatk1.0-dev:i386 (>= 1.29.2) but it is not going to be installed
                      Recommends: python:i386 (>= 2.4) but it is not going to be installed
portaudio19-dev:i386 : Depends: libjack-dev:i386
E: Unable to correct problems, you have held broken packages.

Are their newer versions available or is there a way to install these?

Sponsored links

Ubuntu has a not-so-good multiarch system, that has not been fixed after several years. You could try to install a 32bit version of Ubuntu in Virtualbox and compile there, and move the finished PCSX2 product to your main 64bit distro. Otherwise, wait until Gregory updates the PPA.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti

Well great...

Well your solution worked. I made a virtual x86 Xubuntu installation (in VMware though Wink), and compiled it in there.
Then i've moved over the whole directory to the host and played it from there.
It worked perfectly, it made my game playable!

Is there anyway to properly install the game now so I can:
- run "pcsx2" from the terminal without being in a specific directory
- launch it using Ubuntu Dash
to launch it from terminal without a specific directory you'll need to add pcsx2/bin to your path.

add the following like to ~/.bashrc
export PATH=$PATH:/path/to/pcsx2/bin
Then close and reopen your terminal. You should be able to just issue 'pcsx2' without navigating to the directory.
Main Rig: i5 4670k, 16GB RAM, Nvidia 770 GTX, Windows 8.1/Arch
Main Laptop: Toshiba Kirabook. i5 4200U, 8 GB RAM, windows 8.1/Arch

Users browsing this thread: 1 Guest(s)