Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't play games... (Solved)
#1
So, there's this error message that keeps on popping up for me that keeps saying the GS plugin failed to open, assuming that my PC sucks so bad it can't run the emulator, I downloaded this emulator like 2 years ago on this same PC, ran smoothly and had few issues with it, now this happens when I install it again, what do I do? I tried every other plugin option there is on the screen it sends me to every time it fails to open the GS plugin, tried everything there, didn't work at all. My specs are Intel i7 6700, Nvidia Geforce GTX 960M. Before anyone asks, I tried updating my graphics card, didn't do jack chicken.
Reply

Sponsored links

#2
install "DX redist" and "visual C++"....same as the rpcs3 quickstart guide that they required.
https://rpcs3.net/quickstart

it goes like this 2 screenshots.


Attached Files Thumbnail(s)
       
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
(01-05-2018, 04:16 AM)smartstrike Wrote: install "DX redist" and "visual C++"....same as the rpcs3 quickstart guide that they required.
https://rpcs3.net/quickstart

it goes like this 2 screenshots.

First of all, as mentioned in my post, I have the latest version of Microsoft Visual C++, and secondly, why did you post a link to the site for the PS3 emulator? That doesn't help one bit.
Reply
#4
Check which GS plugin you are trying to run. There is an AVX2 build and a SSE4 build of GSdx, and certain CPUs, mostly old ones, can't run the AVX2 plugin.

Edit: he linked the RPCS3 page because it's the same two VC and DX redistributions that PCSX2 requires, probably.
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ RGB Series, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070Ti FTW2 (8 GB)

Oh yeah Red Pandas are cool too.

Reply
#5
(01-06-2018, 05:33 PM)Gravyos Wrote: First of all, as mentioned in my post, I have the latest version of Microsoft Visual C++, and secondly, why did you post a link to the site for the PS3 emulator? That doesn't help one bit.

That was his error, it wasn't intentional.

Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]
Reply
#6
Oh sorry, I actually paid attention to his post, when I double-checked his post again, I found that I needed to download something called DX redist, installed, it worked wonders! I apologize for inconveniencing you all for no reason, and major props/kudos to my guy Smartstrike.
Reply




Users browsing this thread: 1 Guest(s)