Can't run 0.9.7 due to missing library
Hello guys, this is my first post here. I'm not much of a console games fan, but occasionally there are some games I want to play. I have noticed that the beta 0.9.7 version of PCSX2 emulator is supposed to be able to run PS2 classic "Shadow of the Colossus" so I've downloaded Linux version from the site. Unfortunatelly, the program doesn't start and when I run it from terminal, I get as a reply

pcsx2: error while loading shared libraries: cannot open shared object file: No such file or directory

First thing that popped into my mind was that it's probably a 32-bit PCSX2 asking for a library not present on my 64-bit Ubuntu 10.04. I've installed library pack that someone made for 0.9.6 version of the emulator, but it didn't do the trick. Does anyone know there I could get the missing library, or is there a deb package of PCX2 or some repo that I could install it from?

Generally, how is PCSX2 performing under Linux? I could run it in Windows if I don't find other solution, but I prefer using my Ubuntu.

Sponsored links

Dunno much about the linux library stuff but playing in linux and mac would be slower because you have to use openGL.
The faster plugin is gsdx which uses directx so don't except good speeds Wink
[Image: 1201126.png]
+ ZOTAC 9600GT 1GB + DG41WV mobo
I have the same issue running the binary on my Ubuntu 10.04 AMD64 install.

Any ideas? Besides maybe installing the 32bit version of Ubuntu...

I've tried solving dependencies by using getlibs tool, it does end up installing two needed libraries, but I end up with...

./pcsx2: /usr/lib32/ version `ZLIB_1.2.3.5' not found (required by ./pcsx2)
./pcsx2: /usr/lib32/ version `ZLIB_1.2.3.3' not found (required by ./pcsx2)

...terminal message that I cannot solve.

According to this diveloper's post, there is no way of making this 32-bit app run in 64-bit OS.
The only provided workaround is running PCSX2 in chroot, but that really is a huge overkill, like swating a fly with a canon, I'd rather just run it in crummy Windows. It really should not be too difficult for someone to bundle the app and all the correct versions of 32-bit libs it uses into a single package that could be installed on 64-bit Linux. If it's too much work to package it for all the major distros, package it at least for Ubuntu 10.04, over half of all Linux users use that.
I have the same problem with Lucid 32bit, so it's not a 64bit related problem.

Running pcsx2 gives this:
./pcsx2: /lib/ version `ZLIB_1.2.3.5' not found (required by ./pcsx2)
./pcsx2: /lib/ version `ZLIB_1.2.3.3' not found (required by ./pcsx2)

altough the file is in the lib directory ( version
I'm using Ubuntu 9.10 32bits and get the same error Wacko
./pcsx2: /lib/ version `ZLIB_1.2.3.5' not found (required by ./pcsx2)
./pcsx2: /lib/ version `ZLIB_1.2.3.3' not found (required by ./pcsx2)

I tried to install zlib but apt-get says that it's already installed. What could we do?
Here's a recompiled version of pcsx2 that has a copy of zlib built in. Just substitute the copy of pcsx2 in the tar.gz file for the one in the pcsx2 folder. That ought to take care of the zlib errors.

(The error on the first post, OTOH, is because the gui was totally redone in wxgtk, so it needs a 32 bit copy of that library installed.)
Thanks arcum42! I solved the problem downloading, compiling and installing latest version of zlib (1.2.5) but now I get other error message:
./pcsx2: relocation error: ./pcsx2: symbol _ZN12wxSizerFlags24ReserveSpaceEvenIfHiddenEv, version WXU_2.8.8 not defined in file with link time reference

I tried with your recompiled version, but get the same error. So I downloaded latest version of wxWidgets (2.8.11, wxGTK), compiled and installed it but there's no way. The error persist Wacko

Some idea?
Same error here on Ubuntu 10.04 32bit:

./pcsx2: relocation error: ./pcsx2: symbol _ZN12wxSizerFlags24ReserveSpaceEvenIfHiddenEv, version WXU_2.8.8 not defined in file with link time reference

EDIT: This thread helped me get it running perfectly!

Emulation of 3D games is still REALLY SLOW tough (24fps) and my system specs aren't that bad. Any help?
To wingnux

Hello ? I have the same error message.
I followed your link and tried every describe there but I still see the same error message.
* I already visited following link *

Can you explain how did you fix it ?

I am using Ubuntu 10.04. 32bits


Users browsing this thread: 1 Guest(s)