Can't seem to get Star Ocean 3 to work properly
I have the game fix on. Problem is, after the intro screen when I can choose to start a new game or load a game, it freezes, and the screen shakes a bit.

Specs are

E7200 Core 2 Duo 2.46 Ghz
HD4850 GPU
Windows 7 64 bit.

Sponsored links

any error in the ocnsole log ?
which pcsx2 version are you using ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
I'm using 0.9.7, the newest version. I think it's still in beta but it was recommended to me.

Console log:

microVU1: Cached MicroPrograms = [062] [PC=0572] [List=01] (Cache = 2.524482%)
microVU1: Cached MicroPrograms = [063] [PC=00f7] [List=02] (Cache = 2.524482%)
microVU1: Cached MicroPrograms = [064] [PC=0570] [List=01] (Cache = 3.104418%)
microVU0: Cached MicroPrograms = [006] [PC=015d] [List=01] (Cache = 0.449753%)
microVU0: M-bit set!
microVU0: Cached MicroPrograms = [007] [PC=0154] [List=01] (Cache = 0.523853%)
microVU0: Cached MicroPrograms = [008] [PC=016c] [List=01] (Cache = 0.570393%)
microVU0: Cached MicroPrograms = [009] [PC=0191] [List=01] (Cache = 0.720882%)
microVU1: Cached MicroPrograms = [065] [PC=00dc] [List=03] (Cache = 3.143737%)
microVU1: Cached MicroPrograms = [066] [PC=04f2] [List=01] (Cache = 3.143737%)
microVU1: Cached MicroPrograms = [067] [PC=0551] [List=01] (Cache = 3.143737%)
microVU1 Warning: Branch in Branch delay slot! [2a90]
microVU1: Cached MicroPrograms = [068] [PC=055a] [List=01] (Cache = 3.143737%)
microVU1: Cached MicroPrograms = [069] [PC=00f7] [List=03] (Cache = 3.143737%)
microVU1: Cached MicroPrograms = [070] [PC=055c] [List=01] (Cache = 3.562557%)

I see no errors, but there's a warning. not sure what it means.
Config -> Emulation Settings -> Game Fixes
Put a check in the top gamefix.
You can mouse over it to see it says Star Ocean 3.
That should fix the crashing issues.

To get rid of the "Shakes" there are two options:
Option One
Config -> Video -> Plugin Settings.
Set "Interlacing" to "Blend bff (slight blur, 1/2 fps)"
NOTE: Gameplay doesn't look as smooth as Option Two.

Option Two
After you select "Boot Fast" in PCSX2, hold down X and Triangle on your gamepad until you see the enable screen for Progressive Scan Mode.
Enable it.
NOTE: In game FMVs (including the opening) will be jerky.
However, FMVs are smooth if you use option one instead.

Also, regardless of the Option you pick, you might have to push the slider for "VU Cycle Stealing" in Speedhacks (Config -> Emulation Settings -> Speedhacks) up to "2" in order for the menu screen to run at fullspeed.
My PCSX2 Rig:Windows XP x32 & Windows 7 x64.
i5 2500k @ 4.0 GHz.
nVIDIA GTX 460 1 GB.
>Dun Click Here<
Like I said, the Tri Ace game fix is already on. It's not crashing on start up, I can see the intro screen and stuff. It's freezing when the start new game screen comes up. And thats when the sound cuts out and the screen shakes as well.
Full pcsx2 and plugin settings?

Try remaking the ISO if running from one and try making an ISO if you aren't currently, you could also set PCSX2 to run from plugin (Cdvd > plugin) and select "linuz ISO cdvd" as the cdvd plugin (config > plugins).
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Looks like a bad rip. Try ripping from DVD again. I was able to run it fine on default PCSX 0.9.7 settings with just the Tri-Star games fix enabled.
CPU: i7 930 @ 2.8GHz(Everyday)/3.6GHz(Gaming)/4.0GHz(Encoding)
GPU: Geforce GTX 480 @ 850MHz/1001MHz
Motherboard: ASUS P6X58D-E
RAM: 2x3 6GB OCZ @ 1527MHz 8-8-8-24
You don't need to use an interlace option with star ocean 3, if you read the text when you start you can hold a button (forget which one off the top of my head) to enable progressive scan mode. Doing so removes the shakey interlace image.
[Image: 2748844.png]
And use SPU2-X as sound plugin.
It should really work then. Otherwise you'd be the first person to have it hang there Tongue2

Users browsing this thread: 1 Guest(s)