Can't start any games, halp me please
Ubuntu 13.04
AMD athlon x2 3.4ghz dual core
radeon hd 6450 with latest proprietary drivers, supporting opengl 4.2 (the linux drivers support opengl 4.2, I've tested with my own software and other software)

Upon starting pcsx2 with terminal, about 20 error messages show, all the same error. This is the error:
(pcsx2:17856): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': pcsx2: undefined symbol: menu_proxy_module_load

Then, pcsx2 loads and runs fine. Using gsdx video plugin, both hardware and software mode fails. This shows up in the terminal:
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
Failed to create the opengl context. Check your drivers support openGL 3.3. Hint: opensource drivers don't

Then I have to force quit pcsx2.

I've also tried zzogl with the same effect. Installed pcsx2 from ppa:gregory-hainaut/pcsx2.official.ppa
Installed the only version found there, the unstable version.

If there is any more information I need to give, let me know. I'd really like to play some of my ps2 games to procrastinate and detach myself from reality.

Sponsored links

You didn't install the 32bits part of the catalyst driver. So in your 32bits you're running the open source driver.
sudo apt-get install fglrx ... should install both 32 bit and 64 bit version of Catalyst.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti

I have yet to understand how someone can give me an answer that involves me having to figure out something obscure to install. Thanks DaTankAC for the REAL answer. Installing atm, will reply if it works.
Okay, installed, restarted, and tested. Result: Half n Half.

Tried about 15 times to start a game in hardware mode, only managed to work once, on the zzogl plugin. Even then the framerate is nothing like it is on windows, messing with the speedhacks helped the framerate, but everything in the game still moves as if it was at a low framerate. Software mode works every time, but really, that won't be playable for many years to come.

I noticed when the game doesn't start, I get an error in the pcsx2 log window that says "ELF is not on path" or something like that. When starting games, the terminal says:
glX-Version 1.4 with Direct Rendering
Supported Opengl version: 3.3.11986 Core Profile/Debug Context on GPU: AMD Radeon HD 6450. Vendor: ATI Technologies Inc.

I really hate having to switch to windows for any time I want to do something game related, but it seems I have no choice. Thanks for the help.

Not to mention I now have a box in the bottom right corner of my screen saying AMD Unsupported hardware
It's true the main version is software mode only and therefore slow. However, great progress has been made with the open source driver on the developmental branch and I got it to compile today and tested it. It will be a little while longer till its merged with the main branch, because there are more kinks to work out.

Oh, and don't worry about that unsupported hardware nonsense.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti


Users browsing this thread: 1 Guest(s)