Cannot Initialize GS plugin
Hey guys, i am obviously a bit new to the PS2 Emu side of this, But I havent ever had a issue configuring my other emulators (Dolphin etc) Anyways to the issue, Whenever i choose ANY Graphics plugin for my computer, it tells me this "Cannot Load GS Plugin 'plugins': <NULL>"

So I did a little research and found out that the error occurs if you do not have Pixel Shader 2.0 on your VGA, but this is not true at all. I have Pixel Shader 4.0 on my computer, so here are my specs and what I was using at the time, Thanks guys Smile

Computer Model: HP Pavillion Dv7
Operating system: Windows 7 Ultimate Edition x64
CPU: AMD Phenom II X3 2.3Gh'z 3Mb Cache L2
VGA: ATI Mobility Radeon 5470 512Mb DDR3 w/DX11 and PS 4.0
RAM: 4Gb DDR3 Dedicated Memory
Revision Number: 0.9.6
If you want me to post my settings let me know, and yes my for future reference my Microsoft Visuals C++ for 05-08 is up to date, along with Direct X 11 installed. Thanks again[/align]

Sponsored links

probably you need to update the DirectX.
Imagination is where we are truly real
(08-17-2010, 08:17 AM)nosisab Ken Keleh Wrote: probably you need to update the DirectX.

Well as I said before in the statement, I have Direct x11 on my computer, so there would be no reason for me to need to update it..thanks though Smile
It's not enough, you still need to update it if did not already. Simply don't rely you have the newest one, "probably" you don't.

Since PS2 is a hard nut to crack and almost every drop of performance matters, it's being created using the newest possible SDKs as soon they are released, the 'bad' from this is it forces the user to actually update too, in the end that's not a bad thing.
Imagination is where we are truly real
Alright well I went on Microsoft and updated my Direct X Components, and my d3D Drives and pretty much anything else on there. But its still pulling up the error message. I dont even have to change ANY settings whatsoever, it automatically pops up.

Is there no other reason that this couldnt be working? Because I know there isnt something wrong with my card, I dont think there should be a issue with it since its recently new and supports all the required specs. =/
Considering your specs it should be enough at least to start with the defaults, hence the reason to suggest the update.

Please tell us at least what is the emulator's version you are using. Now the suggestion is using the official beta if not already.

But does not matter for the current issue, there is something else wrong in the setup.

One common permission and access rights error arises from installing in those "non blessed" C:\Program Files folders, but that still is not what your report points out.

So, paste the content of the emuLog.txt (it's inside the logs folder). Hopefully it can shed some light in this obscure case.
Imagination is where we are truly real
Alright, well the log is blank..I havent the faintest clue as to why. But I will post a screen of my settings and go into more detail. It doesnt just outright crash on me, it just tells me once I press continue the whole GS plugin failed to initialize. And then refuses to boot my Iso and closes period..

And no it is not installed in my Main Disk, I do know somewhat of the crap that it can cause ha, its installed in my secondary partition disk. They are both just 320Gb 7200RPM SATA, so yeah nothing weird <.< and I will reinstall using the Beta and see if I get the same result.

Revision: 0.9.6

Graphics settings
1.DX10 (Hardware Enabled) [Does not matter which I choose]
2.Pixel Shader 3.0 (Tried both 2.0 and 3.0)
3.Texture Filering enabled

Its just the defaults, I barely changed anything besides the Direct X plugin. But I will see if i can get something out of the Log files because it just shows you what the screenshot does basically in log screen on startup, except my screenshot shows my settings as well.

Attached Files
.pdf   Settings.pdf (Size: 264,24 KB / Downloads: 223)
Oh and dont forget the only reason the Video plugin is on SSSE3 is because I just left it there, It doesnt matter which plugin I choose for the Emu it ALWAYS comes up no matter what.
I suggest you download and use the latest 0.9.7 beta:

Just backup your BIOS files and delete your old install, then copy the files you backed up to the new installation bios folder

Also install PCSX2 to a new directory, like D:/PCSX2 to prevent all the permission issues and whatnot.
[Image: newsig.jpg]
Well, your CPU allows only SSE2 but you told have tried all. It may not be a plugin issue. Actually I can't imagine anything since there is no message at all.

Your CPU is a bit slow for many games you'll eventually play, sadly at the moment is not possible to use more than 2 cores, thread synchronization problems due to the ps2 pipeline model and several actual hardware processors to emulate :/ But it obviously is enough to get things running.

If the issue repeats with the beta I'll be at loss (at least if no more clear error message comes out). Maybe someone that passed for something similar or one the devs can help you now.
Imagination is where we are truly real

Users browsing this thread: 1 Guest(s)