Cannot build PCSX2 Debug version with VS2008
After testing some of my programming on PCSX2 I was unable to get one of my ELFs to run, so I decided I wanted to build a debug build of PCSX2 so that I could attempt to figure out the bug in my code (at least I am quite sure it's in my code).

So I checked out the code from SVN and launched the VS2008 solution file and built everything running into a few errors (most related to that I do not have the DirectX SDKs installed, which I don't care about right now). But I am also experiencing a linker error with PCSX2 and the x86emitter, it cannot resolve the symbol __xgetbv on line 264 of cpudetect.cpp. I've been going through the code for a couple of hours and cannot figure out why the symbol becomes unresolved.

Does anyone have a clue what could be wrong or if I am doing something wrong? As far as I know I have all dependencies except for the DirectX SDKs and I legally own my copy of Visual Studio 2008 (which is updated to latest SP). Running Windows Vista and the PC I am trying to build it on is an Acer Timeline 3810T. And before someone makes the comment about this laptop not being able to run PCSX2 at a decent speed: I am aware that this laptop will never run PCSX2 at a decent speed, and I don't really care, I just want to debug my code and not play games.

Thanks in advance for the assistance.

Sponsored links

__xgetbv is an intrinsic so after thinking about it, I can only guess you're trying to build for the wrong platform. The only platform which pcsx2 will compile and run on is Win32. x64 is selectable because of other projects in the solution, it's an annoying thing visual studio does.
I checked and everything is being built as Win32, still got the problem though. My Vista installation is 32-bit and was shipped with the laptop when I bought it but the CPU itself is 64-bit. But that should not be causing the problem?
Nope, shouldn't be a problem (or rather absolutely is not a problem, all of us have x64 processors and most if not all of us use x64 windows editions). In that case I don't know, I just know that your visual studio installation must be at fault if you're building the right target because it certainly does build. Maybe there was a problem with the service pack installation, I had issues with that in the past. Try uninstalling everything and installing from scratch (a pain and takes ages, I know).
__xgetbv, that sounds like part of the xbyte or whatever its called in GSDX. its possible some of the profiles for GSDX are slightly out of date, id check the included libraries etc between the release sse2 profile and the debug one, see if anything is missing. Its entirely possible the files just aren't in the project or something silly like that.

do you have any further errors?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
I do not have any other errors, I checked through the project files and all projects that the pcsx2 project depends on seem to be up to date on the debugging side (compared to Release SSE2). I tried to build Release SSE2 just to see if that one would work, but that one fails too, same unresolved symbol, different error code (LNK2001).

I uploaded the build logs on a friends DropBox just in case they can provide any hints to the problem, I looked at them myself but could not find anything that sticks out.
after updating to SP1, did you run the cleanup function on the project?
I updated to SP1 several years ago, long before I checked out the PCSX2 source code for the first time.
(07-01-2012, 01:37 AM)refraction Wrote: __xgetbv, that sounds like part of the xbyte or whatever its called in GSDX.

xbyak and no, it's just the compiler intrinsic for the xgetbv instruction. If you're getting a linker error with an intrinsic, that means that your installation is broken and searching the internet it does seem that VS2008 without SP1 was missing this intrinsic.
Then my SP1 installation must have silently failed to install a (few) file(s), I will reinstall VS2008 and try again. I will let you know in a day or so if that fixed it.

Users browsing this thread: 1 Guest(s)