Cannot get PCSX2 to work at all
I followed the guide step-by-step, and spent hours trying to configure it and reading the forums here trying to find threads that might help. Everytime I start the emu, it says I need to configure it. I do so, and everything tests fine. Then, I put in a game disc and try to play it. Everything immediately starts to crash. I get messages about null plugins, then stuff about needing to update my DirectX (even though the version it links me to is older than the DX10 I have installed), and then errors about not being able to access the memory card files, and finally it says stuff about fatal errors and having to close. I am not home at the moment, but does this sound familiar to anyone? I feel like there is some basic step that I missed or one big thing I am doing wrong that is messing everything up. Also, my configuration settings are not being saved at all.

When I get home this afternoon I will get some screens and detailed error messages.

If it makes a difference, my computer is running Vista on a C2Q, 4GB RAM, integrated graphics. Not expecting miracles, just want to get it working so I can finally ditch the console (TV broke, my nice computer monitor lacks TV inputs).

One thing I am wondering about are the plugins. Is the official copy of the emu supposed to come with them? Because I downloaded both the official copy, and a second copy that was bundled with updates and plugins and other junk. I installed the official one, and may or may not have copied the plugins from the bundle to the install directory (cant remember now that I have been messing with it so much). I tried uninstalling the program and reinstalling it, but it did not fix anything; exact same errors and messages.

Sponsored links

First of for settings to save you need to use "Run as administrator" or install pcsx2 in a folder you have rights to.

Secondly, if it tells you to update directx do so. Im pretty sure it links to the Direct-X End-User Runtime which automatically updates your directx to the latest version.

After this try configuring the emulator again and see if it works.
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Ok, I updated DX and moved the PCSX2 folder to the desktop. My previous problems are solved. I tried to load Katamari, and as soon as the opening movie starts to play the game suffers a severe slow down to the point where it just stops. It seems that the GSdx9 graphics plugin is the only one that works for me, using the DX9 renderers (hardware/software does not seem to matter). I have tried going through every graphics setting, nothing changes.

I am not understanding why the DX10 renderer is not working. When I run dxdiag, it says I have DX 10, yet the plugin fails to initialize using the DX10 renderers.

EDIT: Nevermind, I found the patch. I have been playing with all the CPU and Advanced settings for about an hour now, and cannot get the mess of grey polygons to go away. It seems to be a common problem with Katamari, but all the fixes that people suggest on here do nothing for me.
First, delete your whole PCSX2 dir except the bios folder.
Get: The beta 1888 and the December 30 plugins from here
Post your system specs. It looks like your graphics card does not support DX10.
[Image: newsig.jpg]
I thought the beta comes with the latest plugins?
(02-17-2010, 11:23 AM)codemasterda Wrote: I thought the beta comes with the latest plugins?

No, these have been the latest plugins in september (the beta came out then, didn't it^^?). But in december, newer version have been published. And some months can make a nice difference Smile.
Rejoice, they say. Color is back.
(02-17-2010, 09:26 AM)Bositman Wrote: First, delete your whole PCSX2 dir except the bios folder.
Get: The beta 1888 and the December 30 plugins from here
Post your system specs. It looks like your graphics card does not support DX10.

I tried this, and now I cannot even get PCSX2 configured. I downloaded the 1888+Sept. plugins pack, and copy/pasted the Dec. plugins to the plugin folder, and they are not recognized. Deleted that directory, installed the 1888 version without plugins and then copy/pasted the Dec. plugins to a new folder labeled 'plugins', and it still does not work. Over half the plugins are not recognized, and the only ones that are seen are the ones that were also included in the Sept. release. EDIT: fGot most of them recognized by setting the Plugins directory again, but some are still missing. Does the Dec. pack not include all the plugins?

My desktop is a ZT, with C2Q Q9300, 4GB RAM, WinVista x64, and integrated graphics (Intel G31/G33 I believe it says). I had Persona 4 playing just about perfectly last night, though I never did fix the Katamari problem. My integrated graphics are doing <I>something</I>, because the hardware rendering gives me ~10% better FPS compared to software, while taking a huge load off the CPU (all 4 cores running 100% with software vs. all 4 running 20-80% each with hardware).
You need to update your directX:
You should get the 1888 pack with plugins, then extract the December 30 ones in the same plugin folder. Also make sure the wpthreads dll included is placed in the directory pcsx2.exe is at.
These 2 should include all plugins you might need.
[Image: newsig.jpg]
Ok, that got the plugins and everything working, but still having the same problem with Katamari (grey polygons everywhere).

Is this a problem with the software? Will getting a videocard fix this? Because that is on my to-do list.

Also updating DX was one of the first things I did. It fixed a lot of my original problems, but I am still stuck.
Yeah that should be it I guess, that onboard gfx card is causing your problems. It works fine here. Can you even use Pixel shaders 3 in GSdx?
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)