Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cant remap analog sticks for Armored Core 2
#1
(07-09-2017, 01:24 AM)DrDankness Wrote: Hello. Im trying to remap my wireless xbox 360 controller (for pc) so i can more comfortably play AC. Right now movement and the camera are controlled by the d pad which is very annoying. Im trying to remap my right and left on the d pad and my right sticks left and right. It seems to map fine in the config, but then once i go into the game it wont work. I set the select button to mimic the analog button and still nothing. Any help is appreciated!

Im running lilypad 0.11.0 and pcsx2 1.4.0.

I'm having this exact problem but I'd rather not add another thread to spam the same issue needlessly, so let's dig this baby out of the graveyard.

I HAVE noticed that when I switched it over to Pokopom that the analog sticks DO work, but only in the Nerves Concord menu. When it comes to the actual piloting in game, however, they're non-functioning. Clicking the thumb sticks still triggers the L3 and R3 buttons, but I get no movement for either my AC or my camera.

I'm ALSO running PCSX2 1.4.0.
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Like it says in the quote there, the mapping goes fine but the game just doesn't do anything. This log just shows me switching back to lilypad to try to make it work again.

I've tried increasing sensitivity, messing around with the dead zone, assigning the Analog button to my keyboard and hitting it several times, and I made sure that direct input was turned off while leaving xinput on.

Code:
EE/iR5900-32 Recompiler Reset
    Opening GS
Current Renderer: Direct3D9 (Hardware mode)
NVIDIA GeForce GTX 1060 6GB (23.21.13.8813)
    Loading GS
    Loading PAD
    Loading SPU2
    Loading CDVD
    Loading USB
    Loading FW
    Loading DEV9
Opening plugins...
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: D:\Armored Core 2 (USA)\Armored Core 2 (USA).iso
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1731888 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0 [File]: C:\Users\Owner\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\Owner\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
Suspending single plugin: PAD
    Saving PAD
    Closing PAD
Recovering single plugin: PAD
    Loading PAD
Opening plugins...
    Opening PAD
Plugins opened successfully.
Loading savestate from slot 0...
    filename: C:\Users\Owner\Documents\PCSX2\sstates\SLUS-20014 (0D168765).00.p2s
EE/iR5900-32 Recompiler Reset
    Loading GS
    Loading PAD
    Loading SPU2
    Saving GS
    Saving PAD
    Saving SPU2
    Saving CDVD
    Saving USB
    Saving FW
    Saving DEV9
Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
    Closing PAD
    Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.

Loading plugins...
    Binding   GS: C:\Users\Owner\Desktop\PS2\PCSX2 1.4.0\Plugins\gsdx32-avx.dll
Windows 10.0.17134
    Binding  PAD: C:\Users\Owner\Desktop\PS2\PCSX2 1.4.0\Plugins\lilypad.dll
    Binding SPU2: C:\Users\Owner\Desktop\PS2\PCSX2 1.4.0\Plugins\spu2-x.dll
    Binding CDVD: C:\Users\Owner\Desktop\PS2\PCSX2 1.4.0\Plugins\cdvdGigaherz.dll
    Binding  USB: C:\Users\Owner\Desktop\PS2\PCSX2 1.4.0\Plugins\USBnull.dll
    Binding   FW: C:\Users\Owner\Desktop\PS2\PCSX2 1.4.0\Plugins\FWnull.dll
    Binding DEV9: C:\Users\Owner\Desktop\PS2\PCSX2 1.4.0\Plugins\DEV9null.dll
Plugins loaded successfully.


Initializing plugins...
    Init GS
Windows 10.0.17134
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

EE/iR5900-32 Recompiler Reset
    Opening GS
Current Renderer: Direct3D9 (Hardware mode)
NVIDIA GeForce GTX 1060 6GB (23.21.13.8813)
    Loading GS
    Loading PAD
    Loading SPU2
    Loading CDVD
    Loading USB
    Loading FW
    Loading DEV9
Opening plugins...
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: D:\Armored Core 2 (USA)\Armored Core 2 (USA).iso
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1731888 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0 [File]: C:\Users\Owner\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\Owner\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
Suspending single plugin: GS
    Saving GS
    Closing GS
Recovering single plugin: GS
    Opening GS
Current Renderer: Direct3D9 (Hardware mode)
NVIDIA GeForce GTX 1060 6GB (23.21.13.8813)
    Loading GS
Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
    Closing PAD
    Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
(GameDB) Unloading...
Reply
#4
give latest GIT a try
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
GIT? Sorry I'm not especially familiar with all the latest terms... You got a link or something?

Edit: Downloaded the latest one, did not work.
Reply
#6
Tried it again with the latest GIT from lightning terror, nothing seems to be working. Are there any other options I could try?
Reply




Users browsing this thread: 1 Guest(s)