Castlevania Cuse Of Darkness, trouble with player running
I am attempting to play Castlevania Curse Of Darkness in v1.4.0 and a very recent 1.5.0 dev build.  I am using all of the default plugins, Windows 7 64 bit, Radeon 5450, Athlon 64 X2.

I can't seem to move the joystick far enough for the player to run.  He walks if the joystick is less than something ridiculous like 95% to the edge of it's movement zone.  I've tried re-calibrating my joystick in windows several times, and each time I get slightly different results, but I am still not able to run in all directions..

I went in the the in-emulator joystick test, and it shows left and right on the stick capping at 1.000, but up and down stop somewhere between 0.940 and 0.960.  No amount of re-calibration will get those to 1.000.

Left and right running are fine.  Up/down/diagonals are causing issues.  There doesn't seem to be an option in the default input plugin to adjust controller sensitivity.

Any suggestions?

Sponsored links

Do you have another joystick that you can use? Maybe your controller has a huge deadzone from being worn down.
Well, that's the thing... yes, it is worn out a bit. But that's what calibrating the joystick takes care of. It adjusts the real range of the joystick to cover the full range of expected joystick motion.

However, it appears that either the input plugin or the emulator is ignoring the calibration and using the raw input values.

So say, for example, in my case my joystick can only move up and down 95% of it's original motion. Calibrating will make that 95% equal 100% for actual usage. But PCSX2 is still showing the 95% as 95%, and not as 100% as it should. If I push the stick up as far as it can physically go, the calibration window shows it all the way up, but the emulator shows it less than all the way up.

DirectX input, with a Mayflash Wii Classic to USB adapter.

Users browsing this thread: 1 Guest(s)