Castlevania Lament of Innocence hiccups
Hey everyone,

I don't know whether this was already discussed or maybe that's just me having this issue, but here it is.

I installed PSCX2 0.9.8 a few days ago and tried Castlevania LOI NTSC on it.
VIDEO: GSdx 4600 SSE4.1
AUDIO: SPU2x-r4600m
INPUT: Lilipad r4510
video plugin resolution was set to 1920x1080 and internal resolution was 3x native.

at first everything worked great. that first day it all ran at constant 60 fps with absolutely no issues, except for absent shadows, which is a known problem with this game.

but, a day later, I ran the game and noticed some strange "hiccups". it's as though everything works as flawlessly as before, only that everyother second or two there is a slight FPS drop like 60->57->60->60->57->60->60->57 etc as though it all freezes for a split second and then continues running normal, but than this micro-freeze happens again and again...
the game seems to be "hiccuping" ...runs smooth, but these slight pauses drive you mad Smile

I don't know what's happening, but it seems to be somehow related to the game loading stuff into memory. cause sometimes when it happens right at the beginning of a level, I can reenter the level and everything is fine. or I'm running through a "hiccuping" room, enter a save room and then come back to the "hiccuping" room and the hiccups are gone. or everything is great and then you enter a boss room and suddenly the issue appears again. you restart the emu, reload your saved game, enter the boss room again - and it's all issues.

I tried many different plugin combinations - it doesn't matter. it happens in all DIRECT3D and SDL (hardware or software) modes and graphics settings do not matter (native or 6x native - all the same).
I also tried playing with SPU sync options - again to no effect.

has anybody seen anything like this? is there a cure?

here're my system specs:
Asus G74 laptop
CPU: core i7 2630QM
GPU: geforce GTX 560M 3Gb
RAM: 12 Gbs
Windows 7 64 bit

thanks in advance.

Sponsored links

What type of harddrive do you have western digital?
(03-18-2012, 04:20 PM)Direct10 Wrote: What type of harddrive do you have western digital?

Does it make any difference if it is not one?
Processor: "Phenom II X4 B55 OC 3.5GHz" GPU: "Sapphire HD 6870" SPU: "Realtek ALC889" RAM: "4GB" OS: "Win 7 x64 SP1"
(03-18-2012, 05:08 PM)millanow21 Wrote: Does it make any difference if it is not one?

Well the reason I asked was because I have an asus laptop that had a similar problem where the game would like freeze for 1 sec then resume. It was caused by some power saving feature of the western digital hard drive.
well..thank you very much Direct10. this seems to be the issue. I don't know what HDDs are inside this laptop, but it seems like I'm having the same issue you've had.
I tried running the game from an external USB 3.0 WD Passport hard drive and it worked flawlessly. I completed a few sections of the game without having any problems. So I guess I'll keep using the external HDD for PCSX2.

did you find a way to disable that "power saving feature" in your WD HDD?

just uncovered another thing - the framerate drops considerably at the Ice Elemental Boss. but everything's back to normal once the boss leaves the screen or is dead. so this is a minor problem.
Yeah I did solved my problem. Download crystal disk info and set the apm to high performance.
Edit link:
When you turn off your laptop the apm setting reverts back to normal. You can set crystal disk info to launch when you start up back your laptop just click on startup in crystal disk info and click auto apm/aam control so the settings will automatically be set to high performance. High performance in apm set to FEH.
Thank you very much. this indeed helped. with that setting you provided, the emulation is flawless now. no hiccups and even no "micro-freezes" between rooms (when you open a door).

this topic might actually be a good addition to the FAQ.

thanks again.
WD Green drives are mentioned in the faq.

Users browsing this thread: 1 Guest(s)