Cdvdiso error when launching via emulationstation
Amd 8320e
Rx580 8gb
Windows 10 64bit

If I launch from the folder it launches fine but when I try to launch it with this entry
    <fullname>Playstation 2</fullname>
    <extension>.bin .cue .img .iso .BIN .CUE .IMG .ISO</extension>
    <command>C:\Users\"Vod Kanakas"\.emulationstation\systems\pcsx2\pcsx2.exe "%ROM_RAW%" --fullboot</command>
It gives the error
PCSX2 1.5.0-20200207115307 - compiled on Feb  7 2020
Savestate version: 0x9a0e0000

Host Machine Init:
    Operating System =  Microsoft Windows 10 Pro (build 18363), 64-bit
    Physical RAM     =  8161 MB
    CPU name         =  AMD FX-8320E Eight-Core Processor
    Vendor/Model     =  AuthenticAMD (stepping 00)
    CPU speed        =  4.018 ghz (8 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  178bfbff 3e98320b
    x86EFlags        =  2fd3fbff

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. FMA

Reserving memory for recompilers...

Loading plugins from C:\Users\Vod Kanakas\.emulationstation\systems\pcsx2\plugins...
    Bound   GS: GSdx32-SSE4.dll [GSdx 20200207115307 (MSVC 19.21 SSE4.1/AVX) 1.1.0]
    Bound  PAD: LilyPad.dll [LilyPad (20200207115307) 0.12.1]
    Bound SPU2: Spu2-X.dll [SPU2-X 20200207115307 2.0.0]
    Bound CDVD: cdvdGigaherz.dll [cdvdGigaherz 20200207115307 0.11.0]
    Bound  USB: USBnull.dll [USBnull Driver 20200207115307 0.7.0]
    Bound   FW: FWnull.dll [FWnull Driver 20200207115307 0.7.0]
    Bound DEV9: DEV9null.dll [DEV9null Driver 20200207115307 0.5.0]
Plugins loaded successfully.

(GameDB) 9858 games on record (loaded in 249ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
    Init GS
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Patches: No CRC found, using 00000000 instead.
Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
Current Renderer: Direct3D 11 (Hardware renderer)
    Opening CDVD
CDVDiso Error: No filename specified.
Closing plugins...
    Closing SPU2
    Closing PAD
    Closing GS
GSdx Lookup CRC:0
GSdx Lookup CRC:0
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
(pxActionEvent) CDVD plugin failed to open!(thread:EE Core)
User-canceled plugin configuration after plugin initialization failure.  Plugins unloaded.
So I dont know what the problem is and I tried the fixes from searching on google with no avail. Anyone know how to fix this?

Sponsored links

Probably the path...quotas are not allowed as part of a folder name in windows and maybe that don infront of emulationstation

C:\Users\"Vod Kanakas"\.emulationstation\
And also about that "CDVDIso Error" in the log...are you using the CDVDIso plugin(PCSX2=>CDVD=>Plugin) or PCSX2=>CDVD=>ISO

Edit:I read your post again and saw that it's not the quotas and I also saw that you are using Gigahertz as CDVD plugin but the question still stays...are you using CDVD=>ISO or CDVD=>Plugin
Its set to pcsx2>cdvd>iso and when it launches the pcsx2 window says ISO in bottom right corner. So what is making it think that its selecting the plugin?

Edit: So i tried just moving the pcsx2 folder to C:\pcsx2\pcsx2.exe and some other locations as well though it launches normally but doesnt seem to like the "Vod Kanakas" folder. maybe this is a emulationstation issue?
1.Try starting the game again.
2.Run taskmanager and click on more details
3.In the Processes tab right click on the columns and enable "Command Line"
4.Check if the path to the game is properly sended and if it have quotas if the path contains spaces)

I get the same error when I use wrong path to the iso(which can also be a path with no quotas that have spaces in the path\game name)
C:\Users\"Vod Kanakas"\.emulationstation\systems\pcsx2\pcsx2.exe "D:\RetroPie\roms\ps2\DH1-Infection.iso"
 that is whats shown in task manager which is the correct path for the iso no spaces even in name of the file
Quote:C:\Users\"Vod Kanakas"\
the problem lies here.
you have double quotes in the middle of your command line.
it's badly interpreted by your OS
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
found to be a workaround for my situation and it works fine that way. ty guys

Edit: on another note you can also use shortnames for the folder with the space in it.

Users browsing this thread: 1 Guest(s)