Champions of Norrath & Champions: RTA problems. (Slowdowns)
#1
Hey guys! First of all I would like to say, awesome emulator! It's incredible how beautifully some of my other favorites games run on it. Thank you for all the work you're putting in on it.

Now maybe I'm doing something wrong, or maybe this game is having a weird regression somehow but I can't get either Champions of Norrath or Champions Return To Arms to run a normal speeds. I get serious frame dips all over and they become kinda unplayable. Any suggestion or ideas what it could be? I tried Vulkan, OpenGL, Software mode, default settings, suggested settings, etc.. nothing seems to work. I've included log file in case it helps.
.txt   emulog.txt (Size: 25,98 KB / Downloads: 68)
Reply

Sponsored links

#2
what cpu ?
what is the content of your cheats file ?
how much did you increase internal res ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#3
(10-25-2022, 07:07 AM)jesalvein Wrote: what cpu ?
what is the content of your cheats file ?
how much did you increase internal res ?

Hey Jesalvein, thanks for replaying. On my main computer I'm running...

Processor Intel® Core™ i7-7700K CPU @ 4.20GHz  4.20 GHz
Installed RAM 16.0 GB
Edition Windows 11 Pro
Version 21H2
NVIDIA GeForce GTX 1660 SUPER

I usually run everything at x3 Native, but in this case in order to troubleshoot I also tried x2, Native and fallback Software mode and I see no discernible improvements. Tried all default recommended settings and game specifics like (disable safe features + disable partial invalidation on). 

Last tested using these settings, went down to 14fps on intro and about 22fps during first fight.

[EmuCore/GS]
UserHacks_DisablePartialInvalidation = true
UserHacks_Disable_Safe_Features = true
VsyncEnable = 0
UserHacks_SkipDraw_Start = 4
UserHacks_SkipDraw_End = 4
fxaa = false
ShadeBoost = false
OsdShowFPS = true
accurate_blending_unit = 1
Renderer = -1
crc_hack_level = -1
TVShader = 0
OsdShowMessages = true
OsdShowGSStats = true
OsdShowIndicators = true
OsdScale = 120
texture_preloading = 2
UserHacks = true
AspectRatio = Auto 4:3/3:2
upscale_multiplier = 1


[EmuCore/Speedhacks]
vuThread = true
EECycleRate = 0
 
Including pnach file used
.pnach   90E66BC5.pnach (Size: 357 bytes / Downloads: 70)

These are in software mode, no cheats activated, all recommended settings.
   
   
Reply
#4
Seem to have same issues with similar games like Baldur's Gate: Dark Alliance & Baldur's Gate: Dark Alliance II in case that helps. I read something about a 4 GB patched required for those games but I don't understand what they are or if they are still viable for 1.7 build.
Reply
#5
no you don't need this anymore.
a snowblind engine problem, maybe.

did you set your windows powerplan to performance mode ?

oh, and why are you using software mode ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#6
(10-26-2022, 02:52 PM)jesalvein Wrote: no you don't need this anymore.
a snowblind engine problem, maybe.

did you set your windows powerplan to performance mode ?

oh, and why are you using software mode ?

Seems likely yeah, from what I've been reading they've always been problematic. Yeah my Pc is set up for high performance, gaming. 

And I tried software mode in order to troubleshoot, to see if I noticed any improvements without success. Cycle rate nor renderer seem to have much difference.

Tried a no shadows patch for Dark Alliance 1 and that didn't help either. It's a shame, these were some of my most played games on my original console.
Reply
#7
Back to your PS2, i guess.
At least for now
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply




Users browsing this thread: 1 Guest(s)