Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Codebreaker freezing on swap disc
#1
Ok, I have looked for a solution for this EVERYWHERE and no one seems to know what the issue is. I suspect it has to do with graphic settings or something to do with D3D. It worked for me just fine for every game until I tried using it with Devil May Cry 3 and Star Ocean. I had to change some settings and I don't remember what they were for those 2 games to work ok, then I tried using code breaker and it wouldn't work for those, so I just figured it was because of the game, but then when I tried to use it for games I know it worked for in the past, it STILL would freeze. So there is an option somewhere in either the D3D settings or in the Core GS setting that messes this up. 

I do not want to use a pnach file or whatever because I don't understand it. Has anyone found an actual solution to this?

here is the log right after choosing swap disc and then pressing x

Image type  = DVD
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (1719920 sectors)
Plugins opened successfully.
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_211.68;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_211.68;1) Game CRC = 0x3A446111, EntryPoint = 0x00400008
(GameDB) Changing VU0/VU1 clamp mode [mode=0]

Oh, i forgot to mention I even tried deleting all versions of PCSX2 that i had and reinstalling 1.40, I have been using 1.40 and it worked just fine until I tried changing settings for devil may cry 3.
Reply

Sponsored links

#2
Ok, So I have been able to get it to work by turning off automatic game fixes, but I'm pretty sure star ocean needs automatic game fixes to work, so I am assuming I will never get this to work with star ocean?
Reply
#3
ok, I found that turning off auto game fixes, then turning on the manual game fix add vu hack fixed this issue. thanks anyways guys... i just wasted like 2 or 3 hours of my life trying to fix this and reinstalling and deleting all my pcsx2 files and possibly losing saves from past games, but oh well.
Reply
#4
Try turning off the auto eject from codebreaker settings.
Reply
#5
(08-23-2018, 05:47 AM)vsub Wrote: Try turning off the auto eject from codebreaker settings.

I tried that earlier but it kept giving me errors saying my memory card was full when I tried to save it, this wasn't the issue, it was the automatic game fix option that was messing things up and changing the vu hack on manual fixes fixed the issue with star ocean crashing after codebreaker, thanks anyway, it all works now.
Reply
#6
I've been emulating since the late 90s and this was the first time I can think of where I was scratching my head trying to figure out why something wasn't working. I don't know all the fancy tricks but psx and ps2 emulators are the only ones that have ever gave me problems and it was usually something I could figure out on my own or a little research, so for me to create an account here after i've been using this emulator for around 6 or 7 years just for this one problem says something, luckily I was able to figure it out on my own before anyone needed to really help me. Thanks again though.
Reply




Users browsing this thread: 1 Guest(s)