Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Comp. Specs are Good - FPS Jumping - Kingdom Hearts
#1
Hey all,

I just got my emulator running on PCSX2. However, I'm running into a problem with Kingdom Hearts. From everything I've read it is a very easy game to emulate so I thought it'd be an easy one to get up and running. Unfortunately, no matter what I do in the video settings (software/hardware rendering, all speedhack levels) my fps will jump from 60 down to 50 at some instances.

I understand that I can't expect 100% perfect FPS, but the jumping is very apparent, especially because the background music also slows down because of speed drop. Is there anything you can suggest for why I'm having the problem?

Software Rendering:
EE: 55%
GS: 50%
FPS: 50-60
Maximum CPU Temperature: 65degC

Hardware Rendering:
EE: 30%
GS: 15%
FPS: 50-60
Maximum CPU Temperature: 65degC


Specs:
i3-7100, 3.9 GHz
Nvidia Geforce GTX660
8Gb Ram, 2300 DDR4

Any help would be appreciated. Thank you!

Nick
Reply

Sponsored links

#2
Edit:I didn't see that this is the linux forum
Reply
#3
(06-24-2018, 12:32 AM)vsub Wrote: Edit:I didn't see that this is the linux forum

Sorry about the extremely late reply. Thanks for the edit. I didn't realize, but the post is now in the Linux forum.
Reply
#4
So umm,did you post it in the linux forum by mistake or you are actually asking for help about the linux version of pcsx2

On a MUCH MUCH weaker hardware(on windows)I was able to get between 20-45fps the last time I check(at least 7 years ago)
Reply
#5
Software rendering, as you can see, is harder on your processor. You shouldnt have issues with that speed drop though.

What video card do you have? Are you using the integrated gpu on that i3? If so, that could be some of your issue.. In HW mode, are you doing any resolution scaling, MSAA or anything of the like?

I know I was able to run KH2 at 60 fps on a 2100 stp system.. but that was under windows. I know I had bad luck with nvidia drivers in linux.. under performed by 10% in fedora 27 compared to my windows installs...
amd tr 1950x 
asrock x399 taichi
XFX Radeon rx570
32gb gskill ddr4-3200
Windows 10 Pro
Custom loop water cooled
nzxt 340 case
Reply
#6
(10-17-2018, 06:52 PM)scythefwd Wrote: Software rendering, as you can see, is harder on your processor.  You shouldnt have issues with that speed drop though.

What video card do you have?  Are you using the integrated gpu on that i3?  If so, that could be some of your issue.. In HW mode, are you doing any resolution scaling, MSAA or anything of the like?

I know I was able to run KH2 at 60 fps on a 2100 stp system.. but that was under windows.  I know I had bad luck with nvidia drivers in linux.. under performed by 10% in fedora 27 compared to my windows installs...

Thanks for the reply. I have an Nvidia Geforce 660. Not the best, but I think it should be powerful enough. I am not doing any resolution scaling. Internal resolution is set to native. I've tried many window sizes, from small to large. 

I was thinking maybe it was the developer build (I was using pcsx2 1.5) so I just switched to 1.4, the latest "stable" build. However, now I need to find a way to get onepad 2.0 on here. Onepad 1.1 doesn't recognize dualshock 4 it seems. 

Just to keep you posted on what I've tried: I was running a bit hot (65degC or so) when running the emulator. I know this isn't usually hot enough for thermal throttling the CPU, but I decided to get a new cooler and paste. I am now down at 40degC running the emulator and no change. 

I'll let you know anything else I try. Do you happen to know how I can download the plugin Onepad 2.0 so I can get the dualshock 4 connected?

Thanks a lot for the continued assistance, 

Nicholas
Reply
#7
(10-17-2018, 12:20 AM)vsub Wrote: So umm,did you post it in the linux forum by mistake or you are actually asking for help about the linux version of pcsx2

On a MUCH MUCH weaker hardware(on windows)I was able to get between 20-45fps the last time I check(at least 7 years ago)

Sorry vsub, didn't see this post. I am running Ubuntu 18.04, so I am asking about the Linux version. I thought you meant that I didn't put it in the Linux forum and you moved it there. Misunderstanding. 

Yea, I think my hardware should be up to the job. I am running between 40-60fps at all times, but the random 40fps slowdowns are killing me.
Reply
#8
Hey all, 

I just tried going back to PCSX2 1.4.0 to see if that was the issue (I was previously using PCSX2 1.5.0, developer build). This did not change the problem. Switching back to PCSX2 1.5.0. 

Anyone have any other ideas? Has anyone else ever experienced this problem? I'm going to keep changing things to see what works, and I will post any updates here as I do so. 

Thanks to the community and all who replied so far. It is great to have somewhere to look for help. 

Nicholas
Reply
#9
STR: 2228 defo in the PCSX2 range, Let's get some screen shot's what GSDX settings are you using, speed hacks etc. Also what distro are you using as that can sometimes have a small effect.
Reply
#10
                           
(10-21-2018, 01:30 AM)weirdbeardgame Wrote: STR: 2228 defo in the PCSX2 range, Let's get some screen shot's what GSDX settings are you using, speed hacks etc. Also what distro are you using as that can sometimes have a small effect.

Sure thing weirdbeardgame! Thanks for the reply. Screenshots of settings attached here.

I just tried a few things. By disabling "Blending Unit Accuracy" I was able to get better results. FPS drops still occur, but now instead of going down to 40, 45FPS I am going down to 50FPS. Just to recap, this only happens in certain views, like looking out over the water or at a textured rock, or looking out at a hill with a bunch of texture on it (bunch of texture here being for KH... the actual graphics aren't crazy by any means).

Thanks for checking out the thread and replying.

Edit: I am using the latest distro of PCSX2. Just says PCSX2 1.5.0-0 (git). The package I downloaded should be daily build:
3:1.5.0~git201810192016~ubuntu18.04.1
Reply




Users browsing this thread: 1 Guest(s)