Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Comp. Specs are Good - FPS Jumping - Kingdom Hearts
#11
Okay, so your definitely not doing this wrong, you've got an okay processor try enabling MTVU in speed hacks and disable HW hacks in ogl unless there's a specific thing your using if none of that works let me know.

If it doesn't just know that there were certain areas like the lake next to the shack on destiny island that have always slowed pcsx2
Reply

Sponsored links

#12
   
(10-22-2018, 06:13 AM)weirdbeardgame Wrote: Okay, so your definitely not doing this wrong, you've got an okay processor try enabling MTVU in speed hacks and disable HW hacks in ogl unless there's a specific thing your using if none of that works let me know.

If it doesn't just know that there were certain areas like the lake next to the shack on destiny island that have always slowed pcsx2

Hey weirdbeard,

I implemented your suggestions... no dice. The shack is one of the places that causes a slowdown, but it isn't the only place. I attached a screenshot of one such view. I can leave the view in that orientation and not touch anything and I just shoot down to 40FPS. I also run into the issue with several other games: I've tried Jak and Daxter 1, FFX, and Dark Cloud. I just mention KH because from what I understand it is one of the easier games to emulate.

I just tried lowering EE Cyclerate from -1 to -2. The FPS drops weren't as drastic (40FPS in the screenshot went up to 48FPS or so). Does this mean my CPU is actually the issue? Lowering it to -3 doesn't change anything.

Additionally, is anyone running PCSX2 on Ubuntu 18.04? No chance that the OS or a driver could be causing issues, right?

Thanks for the continued help. I'll post any changes I make that make a big difference.
Reply
#13
I give up for now.. I'll possibly come back to this later.. 3 edits and it still wont format right..
amd tr 1950x                                                amd ryzen 5 2500u
asrock x399 taichi                                          amd vega 8 
XFX Radeon rx570                                         16gb ddr 4 2400 ram
32gb gskill ddr4-3200                                    256gb nvme ssd
Windows 10 Pro                                            480gb sata ssd
Custom loop water cooled                               HP envy x360
nzxt 340 case
Reply
#14
Hey all, 

Just posting some attempts I made. No change for any of the following setting changes:
- Changing available rendering threads to 0
- Enable multi-threading
- Allow 8bit, large framebuffer
- EE cyclerate changes
- VU stealing

No changes I make have a noticeable effect on the game. At this point I'd even be happy just to know what the problem is, even if I can't solve it. Is it my GPU, a connection, a driver, the OS, the ISO? 

If anyone has ANY thoughts or theories on what it might be, or if anyone has had similar problems (even without a solution) I would be happy to hear about it. I haven't seen any posts with a similar problem as mine. 

As always, thanks to everyone in the forum for help, on this thread and the rest. I will post an update the next time I have something to report.
Reply
#15
what video driver are you running? I found the nouveau drivers that get installed by default are .. poor for nvidia cards. That could be some of your slow down.. do you have updated firmware? Are you running in a performance power profile (or cpu frequency governor)? I wonder if whatever performance plan you're running isn't ramping up your cpu frequencies when you're playing.. so you're not at full turbo, just at base clock (which would be considerably weaker). This is all conjecture of course.

I see in your screen shot you're running in windowed mode.. does it change if you run full screen?

does running one of these drivers change anything?
https://www.nvidia.com/object/unix.html

just remember.. back up x configs before you run it.. just general precaution.
amd tr 1950x                                                amd ryzen 5 2500u
asrock x399 taichi                                          amd vega 8 
XFX Radeon rx570                                         16gb ddr 4 2400 ram
32gb gskill ddr4-3200                                    256gb nvme ssd
Windows 10 Pro                                            480gb sata ssd
Custom loop water cooled                               HP envy x360
nzxt 340 case
Reply
#16
(10-30-2018, 09:35 PM)scythefwd Wrote: what video driver are you running?  I found the nouveau drivers that get installed by default are .. poor for nvidia cards.  That could be some of your slow down.. do you have updated firmware?  Are you running in a performance power profile (or cpu frequency governor)?  I wonder if whatever performance plan you're running isn't ramping up your cpu frequencies when you're playing.. so you're not at full turbo, just at base clock (which would be considerably weaker).  This is all conjecture of course.

I see in your screen shot you're running in windowed mode.. does it change if you run full screen?

does running one of these drivers change anything?
https://www.nvidia.com/object/unix.html

just remember.. back up x configs before you run it.. just general precaution.

Hey scythefwd, 

Thanks for the reply! I only just saw it (haven't been on the forums as frequently this past week). I will give your suggestions a try in the next 2 days or so, unfortunately I don't have the time right now. Expect another reply within a few days giving you an update on how it worked! I appreciate the help.
Reply
#17
(10-30-2018, 09:35 PM)scythefwd Wrote: what video driver are you running?  I found the nouveau drivers that get installed by default are .. poor for nvidia cards.  That could be some of your slow down.. do you have updated firmware?  Are you running in a performance power profile (or cpu frequency governor)?  I wonder if whatever performance plan you're running isn't ramping up your cpu frequencies when you're playing.. so you're not at full turbo, just at base clock (which would be considerably weaker).  This is all conjecture of course.

I see in your screen shot you're running in windowed mode.. does it change if you run full screen?

does running one of these drivers change anything?
https://www.nvidia.com/object/unix.html

just remember.. back up x configs before you run it.. just general precaution.

Hey scythefwd, 

Great suggestion! It turns out I WAS running the nouveau drivers. Installing the Nvidia drivers (Nvidia-410 to be exact) really helped. That, along with a few other alterations (listed below) have brought my gameplay up to playable speeds.

 For most actual gameplay I am running between 55-60FPS. On a few of the scenes in the intro (destiny islands, such as when Sora, Kairi, and Riku are speaking on the little island at night) the slow down was huge, to 20-30FPS. But I am now on Traverse Town and nothing like it has happened again.

For others in the forum who may be having this experience, where their setting seems okay and computer specs are enough to play the title (in this particular case, Kingdom Hearts), below is a list of what steps I took (with much help from this forum) and the results. Finally, at the bottom are the current settings and plugins I have along with what I think helped fix the issue:

--------------------------------------------------------------------------------------------------------------
- Started with PCSX2 v1.5.0 (daily build). In certain views, massive slowdown to 40FPS. Started with emulation preset 3. 

- Set resolution to native, no change. Changed between software/hardware rendering, no change. 
- Changed custom window size and aspect ratios to very low res/small screens and up, thinking my window size might be causing issues. No change. 
- Changed available rendering threads from 2 to 0. No change. 
-Enable multi-threading hack. No change. 
- Disable/Enable 8-bit and large framebuffer in video settings. No change. 
-EE cyclerate slider at all levels. Very slight (+4-8FPS or so) change on some views at EE-1 vs. EE0
- VU Stealing slider. No change. 
-Enable MTVU in speed hacks. No change.

-Installed new thermal grease and cooler to lower CPU temps from 60degC to 40-50degC to be sure to avoid any thermal issues. No change. 

-Switched to PCSX2 v1.4 (latest stable release). No change. After switching to 1.4 and trying all my setting changes again, I switched back to PCSX2 v1.5

--------------------------------------------------------------------------------------------------------------
MY CURRENT SETTINGS - 55-60FPS DURING MOST GAMEPLAY at 2 and 3x resolution:
- Emulator Settings Preset 3
-Extra Rendering Threads = 2
-OpenGL(Hardware) Rendering
- Disable "Blending Unit Accuracy" in video plugin. This was the biggest single settings change that helped.
- Changed video plugin to AVX2 (only works with more modern processors)
- Async Mix in sound plugin
- Update GPU Driver: Nouveau Driver (default Linux) --> Nvidia 410 driver 

Edit: After an ubuntu update last night, all my OS display settings were changed back to default. My TV has a 60Hz refresh rate, but the default is 30Hz. By leaving the refresh rate on 30Hz, I now have absolutely no FPS drop. Full 60FPS, all the time as far as I can tell, at 2x resolution.
--------------------------------------------------------------------------------------------------------------
Thanks to weirdbeardgame, Scythefwd, and vsub for sticking with the problem to give me a hand. 

Special thanks to Scythefwd for suggesting the video driver update. That really helped. 

I hope this thread helps anyone else who may be running into a PCSX2 issue where their computer specs seem adequate but the quality is iffy. 

Nichlas
Reply
#18
glad to see you got it sorted out man..
amd tr 1950x                                                amd ryzen 5 2500u
asrock x399 taichi                                          amd vega 8 
XFX Radeon rx570                                         16gb ddr 4 2400 ram
32gb gskill ddr4-3200                                    256gb nvme ssd
Windows 10 Pro                                            480gb sata ssd
Custom loop water cooled                               HP envy x360
nzxt 340 case
Reply
#19
(11-14-2018, 09:04 PM)scythefwd Wrote: glad to see you got it sorted out man..

It's great to have a usable emulator. Runs like a dream on multiple titles so far.

Thanks for all of your help.
Reply




Users browsing this thread: 1 Guest(s)