Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Controller Issues with Castlevania?
#1
Howdy!

I played Castlevania: Lament of Innocence for the first time today and it worked great! Then I went back and played it later on and now the right thumb stick, D-pad and left thumb stick all do the same thing, bring up the items menu.

I've tried a full reset of the controller, no help whatsoever. Reset all the bindings, nothing. The only things I have done since playing it are playing a different ROM (Using the EXACT same controller settings, nothing changed) and played GTA4 on my PC with the same controller (Which hasn't affected any other ROMs before).

Any ideas?

P.S. This is using an XBOX 360 Controller for Windows.
Reply

Sponsored links

#2
are you using lilypad?
may we show us your binding keys only the right analog one

have you tried to bind these prefer on my attachment


Attached Files Thumbnail(s)
   
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
Yes I'm using LilyPad.

Here's what happens when I map my entire controller:


Attached Files Thumbnail(s)
   
Reply
#4
i don't that x360 controller.

does your controller does'nt have a Z rotation and the Z axis?
allthough you just managed to mapped Y rotation and axis in the left analog stick.
that might causing the problem.


Attached Files Thumbnail(s)
   
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#5
That's not a problem if you pick XInput. Try unchecking DirectInput and make everything XInput mapped. Or if you don't care about custom settings, use Pokopom and you'll be ready to go by just selecting the plugin.
Reply
#6
(05-01-2012, 04:13 AM)KrossX Wrote: That's not a problem if you pick XInput. Try unchecking DirectInput and make everything XInput mapped. Or if you don't care about custom settings, use Pokopom and you'll be ready to go by just selecting the plugin.

Thanks man, worked perfectly!
Reply




Users browsing this thread: 1 Guest(s)