Controller bug
I've found a bug where pcsx2 seems to not play nice with the controller. During the first time setup, the emulator would crash after clicking next on the plugin section of the configuration. After trying different things I've read around the internet, I found a post mentioning to unplug the controller. Sure enough, that worked and I finished the set up. Problem is, my computer stopped "seeing" the controller. Wouldn't even acknowledge that it's plugged in. Restarting my computer fixed that. I was able to reconfigure the controller by going into config-controllers-plugin settings without issue. However, after going in there again and then hitting cancel (I didn't make any changes), the emulator crashed again and my computer stopped reading my controller. I was using a dualshock 4 controller through DS4Windows. I also tried using my xbox controller and that didn't work either. I am using the latest build of PCSX2 - version 1.6.0.

Sponsored links

uninstall ds4windows, and give latest git build a try
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
(03-21-2023, 10:56 AM)jesalvein Wrote: uninstall ds4windows, and give latest git build a try

Not sure if it fixed it since I managed to go through the setup before that. Still got the latest build. Didn't realize the build I had was abandoned. Still something to look out for for anyone trying to set it up while having a controller plugged in.
It sounds like you have encountered some issues with PCSX2 and your controller. It's possible that the controller is conflicting with the plugin section of the configuration, causing the emulator to crash. Unplugging the controller seems to have fixed the initial issue, but then your computer stopped recognizing the controller. Restarting the computer resolved that issue, but then you experienced another crash after going into the plugin settings again.

You mentioned using a Dualshock 4 controller through DS4Windows, which is a popular way to use a PS4 controller on a PC. It's possible that the issue lies with DS4Windows rather than with PCSX2. You might try uninstalling DS4Windows and using the controller without it, or try using a different controller altogether.

Additionally, you could try running PCSX2 as an administrator to see if that resolves any issues with permissions. You could also try using an older version of PCSX2 to see if that works better with your controller.

I hope this helps, and good luck with getting PCSX2 and your controller working smoothly.

Users browsing this thread: 1 Guest(s)