Controller issues
(note this is my first post, tell me if it's under the wrong catagory, i've read under bug reports and the like and i'm pretty sure it should go under here. Anyway,)

I recently got this emulator to run Whiplash, (google it if you don't know what it is), the game runs fine. Except when i plug in my xbox one controller, according to my friend, he can get it working with his xbox 360 controller but with me, as soon as it's plugged in the game slows down significantly, and trying to rebind keys causes the emulator to crash, any way this can be fixed?



Note: I'm using the latest version.

Sponsored links

That... is weird.

Post your system specs first, I guess. Not sure how to debug this one @_@
[Image: XTe1j6J.png]
Gaming Rig: Intel i7 6700k @ 4.8Ghz | GTX 1070 TI | 32GB RAM | 960GB(480GB+480GB RAID0) SSD | 2x 1TB HDD
Okay, i warn you: they're kinda crap but it does run games smoothly.. (when the controller isn't in -_-)
and i should also say: to use the xbox one controller, i used xpadder, and set the emulators keyboard controls to my xbox controllers keys

System Information
Time of this report: 3/19/2016, 00:32:32
Machine name: NOVAS-PC
Operating System: Windows 10 Home 64-bit (10.0, Build 10586) (10586.th2_release_sec.160223-1728)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: OptiPlex 745
BIOS: Phoenix ROM BIOS PLUS Version 1.10 2.4.1
Processor: Intel® Core™2 CPU 4300 @ 1.80GHz (2 CPUs), ~1.8GHz
Memory: 4096MB RAM
Available OS Memory: 4030MB RAM
Page File: 4071MB used, 5590MB available
Windows Dir: C:\WINDOWS
DirectX Version: 11.2
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Not Available
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.10586.0000 64bit Unicode

DxDiag Notes
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Input Tab: No problems found.

DirectX Debug Levels
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

Display Devices
Card name: AMD Radeon HD 5450
Manufacturer: Advanced Micro Devices, Inc.
Chip type: AMD Radeon Graphics Processor (0x68F9)
DAC type: Internal DAC(400MHz)
Device Type: Full Device
Device Key: Enum\PCI\VEN_1002&DEV_68F9&SUBSYS_010A1002&REV_00
Display Memory: 2806 MB
Dedicated Memory: 1014 MB
Shared Memory: 1792 MB
Current Mode: 1360 x 768 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: LCD TV
Monitor Id: ___9000
Native Mode: 1360 x 768(p) (60.366Hz)
Output Type: HDMI
Don't use your controller that way. PCSX2 natively supports xinput.

Stop using xpadder and then go to config->controller->plugin settings. The switch over to the Pad 1 tab and bind your controls. It's likely the suspicious way you are using the control is the issue.
[Image: XTe1j6J.png]
Gaming Rig: Intel i7 6700k @ 4.8Ghz | GTX 1070 TI | 32GB RAM | 960GB(480GB+480GB RAID0) SSD | 2x 1TB HDD
Okay, and i tried doing that, that was the way i first used it.. The moment i clicked on a key with my mouse: Emulator crashed..
Alright, i disabled directinput and now it doesn't crash. but it's still quite slow, i unplugged the controller and the speed goes up completely.. i just need to fix this and i'm set
This is a known issue that sometimes happen with Xbox controllers, it's not specific to PCSX2, it can happen with many different pc games. Unfortunately, there is no official fix from Microsoft AFAIK, so you'll need to do a lot of digging yourself I'm afraid.

Have you tried uninstalling and reinstalling the latest Xbox controller drivers? When the game slows down, is there a process in the task manager that have high cpu or memory usage? If you're using a laptop, are you using high performance settings?

Users browsing this thread: 1 Guest(s)