Controller not working, but on other emulators
Hello there.
I'm having a problem. My PS2 controller, which connects to the pc via a "dualshooter" PS2 controller-connector, won't work with the emulator. I've tried SSSPSX and LilyPad, but nothing happens. The device does not show up in the Device Diagnostics.

The weird thing about this is that it works perfectly with both PS1 emulator and SNES emulator. The controller does also show in the win7-device manager.


Sponsored links

I guess not :<
Still in need of help.
Kinda sounds like an incompatible device.
Hard to believe, since anything I've tried worked without a fuss...

I'd say you could consider a new/updated driver for the device, but you say the controller works with everything else, so it doesn't sound like that's really the issue.

Do you by chance not have "DirectInput" checked under "Game Device APIs" (in Lilypad)?
I'll check if there's any new drivers, but as you say, it's very strange it doesn't show up when it works with both snes9x and project64, amongst others.

I do have it checked, but thanks for the tip! All that shows up when I check it is "DX Apple Keyboard", I'm using an apple keyboard for my pc so.. : )

Hmm. This is strange.
I have the exact same problem Sad

I'm using a PS2 dualshock that's connected via something called "Joytech Psx Usb". It used to work fine with Pcsx2 on my old computer (xp) but won't register at all on my new computer (windows 7). I can't assign buttons with either Lilypad or SSSSPX, nor does it show op in the device diagnostics tab.

The controller works fine with another emulator (Project 64) on this pc, so it does seem a bit weird that Pcsx2 won't recognize it. I've tried to find new drivers for the usb adapter, but with no luck, though I'm rather hopeless when it comes to such things....

Any help would be greatly appreciated Smile

Hmm u guys could also have a look for an updated plugin for USB, could be that it's old or a bug with that USB Plugin Smile It doesn't have to do necessary with the driver of your USB Converter Smile
The usb plugin emulates the PS2's usb devices like a keyboard, it has nothing to do with the input plugins like Lilypad which manage your usb controllers etc
[Image: newsig.jpg]
Yay! After mucking about a bit I have finally fond a plugin that at least lets me assign buttons. It's something called "PadWinKey Driver 0.9.0 [PADwin]"

It doesn't seem to work very well with the game I tested (FFXII), and there isn't even an option to assign the analog sticks, but at least the plugin recognizes my pad and lets me assign most buttons Smile

Hopes this helps narrow down what the problem might be somewhat.
Uh that's an ancient input plugin which I guess does not even emulate analog sticks...
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)