Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Controller suddenly stopped working (Steam)
#1
Hi all,

been enjoying PCSX2 for quite a while now through Steam, works like a charm but for some reason it decided to stop working yesterday.

The XboX One controller went from fully functional to not much at all (Start button quits a game, other buttons do not seem to do much).
One thing that suddenly seems to have changed (although I paid no mind to it before) is that the small icon on the game-shortcut within Steam now shows a keyboard instead of a gamepad. Although I do not recall if this was the case before as well, perhaps indicating where the problem lies.

Starting up PCSX2 and playing from there works just fine.

I resetted my PCSX2 config but to no avail.

Any ideas? To my knowledge no updates were installed but hey, you never know, right?

• Intel i7 4770 @ 3.40ghz, NVIDIA GeForce GTX760, 8GB RAM
• Windows 10 Pro fully updated
• 1.50 Daily build 1.5.0-dev-2263
• Wired XboX One Controller
Reply

Sponsored links

#2
I assume the Xbox One controller is detected as an Xbox360/XInput controller, which means it should work by default(though make sure XInput is enabled and controls are setup in the LilyPad settings). If that checks out, you might want to look into the Steam settings.
Reply
#3
Well as we speak I discovered a setting I had to make per game:

Right click on the game in the game list, select Edit Steam Controller Configuration, Click the Browse Configs button, select Gamepad and Apply.

Now it works. No idea why it suddenly changed behaviour. Haven't got much time right now but I will see if I can make it global somehow.

For now it seems to be solved.
Reply




Users browsing this thread: 1 Guest(s)