Controls won't work in game
I cannot get my Logitech Dual Action Gamepad (P/N: 863247-0010) to work in PCSX2 games. Last Summer I had PCSX2 (I don't remember which version) and the same controller and I was able to play through all of Final Fantasy X. Although, I had Windows Vista x64 back then. I've got Windows 7 now, and am still using the same game pad.

I am trying to play the Lord of the Rings series and I've got everything working except the controller. If I start PCSX2 without a game in and it goes to the browser, I can navigate around the menu using the game pad just fine, so I'm sure the game pad or my software isn't the problem. I have the latest Logitech software for my pad and all the tests I run on it work. It shows up on the Device Diagnostics and everything.

Here is a link to a picture of all of my plugin information:

If anyone knows any fixes or help it would be greatly appreciated.

Sponsored links

You need to configure both the Left/Right analog sticks, from that screenshot it looks like you configured the Right analog stick twice instead.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
(05-14-2011, 02:49 AM)Shadow Lady Wrote: You need to configure both the Left/Right analog sticks, from that screenshot it looks like you configured the Right analog stick twice instead.

First of all... You're wrong. Second of all, your input did not help my problem in the slightest. Please troll elsewhere.
Well that seems to be the problem to me from that picture, but whatever then man Tongue2
[Image: 0AscK.jpg]
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
I used to have the same controller before it bit the dust and never had any issues with it win 7 or any of the builds. Second of all she's right you have the right analog configured twice and haven't configured the the dpad at all. Third calling an admin and project contributor a troll isn't a good idea.
A minimal intelligence is expected to notice the star's amount, the number of posts and least but not the last, the number of kudos before believing she would be trolling you. Sadly you showed lack of that most valuable attribute and is to expect no help from many in this forum from now on.
Imagination is where we are truly real
First of all... Playstation 2 is over 10 years old... And you're judging someone's intelligence by the amount of posts and/or their reputation on a forum that deals with an emulator for a 10+ year old console... Kudos man... I hope you feel good about your personal image on the internet.

On a serious note. If I wanted to be trolled on issues that were not related to my particular issue, I would have posted on 4-Chan instead of here. If anyone has serious help regarding my issue, let me know... Otherwise, please stick to your anime and Japanese art.

And if you need more of an explanation, not a single button on my controller works. I even tried reconfiguring Lily Pad for all keyboard buttons and I had the same problem, none of the buttons would do anything past the PS2 browser... Although, before I formatted the memory cards, I could navigate using my Game Pad to choose to continue or not past that particular screen, which was part of the PS2 game, and not part of the PS2 browser.

Anyways, I'm not here to argue with people... Just looking for help.
Show us the first page of your config. So we can see what you have set there and saying your not trying to argue but being an ass and calling someone trying to call someone trying to help you a troll. Especially when that someone is an admin and coder on the project isn't going to do you any favors.
No one here HAS to help you so being civil will help you a lot. Now since you can navigate in the bios menu it seems more of an issue with the game than the plugin, have you tried with ffx which you could play before?
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Step 1: Upgrade to latest PCSX2 (0.9.8, you're currently using 0.9.7)

Step 2: Make sure when you installed the latest PCSX2 that you don't install it in Program files or my documents or windows directory.

Step 3: Clear your controller configuration and reassign keys from scratch.

Step 4: If you're still having issues, feel free to get back to the thread, but remember the golden rule... treat others as you'd like to be treated...
[Image: 2748844.png]

Users browsing this thread: 1 Guest(s)