Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Could not create file" error, regular fixes not working
#1
Hey so I've done a bit of searching around this issue and always seem to come up with the same answers. They're always "run the program as administrator" (which I do) or "install the emulator outside of windows protected folders" (which I've also done). I have PCSX2 installed in my Root (C:\) and I have run the executable as admin but STILL when I try to boot up an iso (same issue whether I choose fast or full) I get the good ol' "Could not create file" error. I couldn't find anything outside of those two answers which I've already tried.
Here's some info about my machine:
intel ci5 3570k cpu
msi z77a-gd65 mb
16gb ddr3 ram
msi r7950 TFIII 3gb VRAM gpu
running windows 8.1 pro

Heres the log file readout when I try to play Shadow of the Colossus:
Quote:PCSX2 1.1.0.r5766 - compiled on Dec 19 2013
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft (build 9200), 64-bit
Physical RAM = 16064 MB
CPU name = Intel® Core™ i5-3570K CPU @ 3.40GHz
Vendor/Model = GenuineIntel (stepping 09)
CPU speed = 3.398 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 7f9ae3bf
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Reserving memory for recompilers...

Loading plugins...
Binding GS: C:\PCSX2\PCSX2 1.0.0\Plugins\gsdx32-sse4-r5350.dll
Windows 6.2.9200
Binding PAD: C:\PCSX2\PCSX2 1.0.0\Plugins\lilypad-r5350.dll
Binding SPU2: C:\PCSX2\PCSX2 1.0.0\Plugins\spu2-x-r5350.dll
Binding CDVD: C:\PCSX2\PCSX2 1.0.0\Plugins\cdvdGigaherz.dll
Binding USB: C:\PCSX2\PCSX2 1.0.0\Plugins\USBnull.dll
Binding FW: C:\PCSX2\PCSX2 1.0.0\Plugins\FWnull.dll
Binding DEV9: C:\PCSX2\PCSX2 1.0.0\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9645 games on record (loaded in 116ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.2.9200
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: H:\Software\Shadow of the Colossus.mdf
Image type = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1315408 sectors)
Opening USB
Opening FW
Opening DEV9
AMD Radeon HD 7900 Series (8.17.10.1247)
McdSlot 0: C:\Users\Patrick\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Patrick\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v01.60(07/02/2002) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
NVM File Not Found, Creating Blank File
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.
Shutting down plugins...
File could not be created.Path: C:\PCSX2\bios\scph39001.nvm
(pxActionEvent) (thread:EE Core)
Plugins shutdown successfully.

Any ideas?? I've followed a couple different config guides through a couple different installs (including trying to run it without tweaking and config options) and always hit the same roadblock. I'm at my wit's end here...

Sponsored links

#2
I even went so far as to turn off UAC not just in the settings panel but in regedit, still no cigar.
#3
Try seeing if the PCSX2 directory is set read only and if so, changing it.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#4
Oh wow, of course it was something that simple and I was just overthinking it. Thank you very much, that did it. Not sure how the directory got set to read only but that was indeed the issue.
#5
#Edit: nvm, was sorted while I was typing >.<

If the above doesn't do it, try: Go to Config -> BIOS/Plugin selector -> BIOS. Then check that you can see the details of your selected bios. Then try unticking 'use default setting' and manually select the location of the BIOS.
#6
I was reading somewhere hat if the folder is read only I may have problems. Everytime I try to change it , it automatically goes back to read only. I even try to change permissions. now when I go to my documents\pcsx2 I notice there are three unknown account names. are those because of the PCSX2 program [img][Image: mcf68x.jpg][/img]


Here is my log file

PCSX2 1.2.1.r5873 - compiled on Feb 3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft Windows 7 Ultimate Edition Service Pack 1 (build
7601), 32-bit
Physical RAM = 3327 MB
CPU name = AMD Athlon™ II X2 245 Processor
Vendor/Model = AuthenticAMD (stepping 03)
CPU speed = 2.912 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = 178bfbff 00802009
x86EFlags = efd3fbff

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3
MMX2 .. 3DNOW .. 3DNOW2.. SSE4a

Reserving memory for recompilers...

Loading plugins...
Binding GS: X:\Games\PS2 Emulator\plugins\GSdx32-SSE2-r5135.dll
(pxActionEvent) (LoadSinglePluginEvent) The configured GS plugin file was not
found(LoadCorePlugins)

X:\Games\PS2 Emulator\plugins\GSdx32-SSE2-r5135.dll
(GameDB) 9655 games on record (loaded in 264ms)
[wx] Failed to load shared library 'X:\Games\ps2emu\Plugins\gsdx32-avx-
r5875.dll' (error -1073741795: unknown error c000001d)
Path: X:\Games\ps2emu\Plugins\gsdx32-avx-r5875.dll
File is not a valid dynamic library.
Some kinda plugin failure: X:\Games\ps2emu\Plugins\gsdx32-avx-r5875.dll
[wx] Failed to load shared library 'X:\Games\ps2emu\Plugins\gsdx32-avx2-
r5875.dll' (error -1073741795: unknown error c000001d)
Path: X:\Games\ps2emu\Plugins\gsdx32-avx2-r5875.dll
File is not a valid dynamic library.
Some kinda plugin failure: X:\Games\ps2emu\Plugins\gsdx32-avx2-r5875.dll

Loading plugins...
Binding GS: X:\Games\ps2emu\Plugins\gsdx32-sse2-r5875.dll
Windows 6.1.7601 (Service Pack 1 1.0)
Binding PAD: X:\Games\ps2emu\Plugins\lilypad-r5875.dll
Binding SPU2: X:\Games\ps2emu\Plugins\spu2-x-r5875.dll
Binding CDVD: X:\Games\ps2emu\Plugins\cdvdGigaherz.dll
Binding USB: X:\Games\ps2emu\Plugins\USBnull.dll
Binding FW: X:\Games\ps2emu\Plugins\FWnull.dll
Binding DEV9: X:\Games\ps2emu\Plugins\DEV9null.dll
Plugins loaded successfully.


Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

[wx] Directory 'X:\Games\PS2 Emulator' couldn't be created (error 5: access is
denied.)

PCSX2 1.2.1.r5873 - compiled on Feb 3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft Windows 7 Ultimate Edition Service Pack 1 (build
7601), 32-bit
Physical RAM = 3327 MB
CPU name = AMD Athlon™ II X2 245 Processor
Vendor/Model = AuthenticAMD (stepping 03)
CPU speed = 2.912 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = 178bfbff 00802009
x86EFlags = efd3fbff

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3
MMX2 .. 3DNOW .. 3DNOW2.. SSE4a

Reserving memory for recompilers...

Loading plugins...
Binding GS: X:\Games\ps2emu\Plugins\gsdx32-sse2-r5875.dll
Windows 6.1.7601 (Service Pack 1 1.0)
Binding PAD: X:\Games\ps2emu\Plugins\lilypad-r5875.dll
Binding SPU2: X:\Games\ps2emu\Plugins\spu2-x-r5875.dll
Binding CDVD: X:\Games\ps2emu\Plugins\cdvdGigaherz.dll
Binding USB: X:\Games\ps2emu\Plugins\USBnull.dll
Binding FW: X:\Games\ps2emu\Plugins\FWnull.dll
Binding DEV9: X:\Games\ps2emu\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9655 games on record (loaded in 264ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
AMD Radeon HD 7800 Series (8.17.10.1247)
Opening CDVD
isoFile open ok: Z:\Game Console\PS2\Resident Evil 4 PT-BR.iso
Image type = Audio CD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1820270 sectors)
(IsoFS) Invalid partition descriptor encountered at block 0x10: ''
Closing plugins...
Closing SPU2
Closing PAD
Closing GS
File not found.
Path: IsoFileSystem
(pxActionEvent) IsoFS could not find the root directory on the ISO image.
(thread:EE Core)
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
#7
Please create a new thread. This thread is over 8 months old, so no creposting. Read the rules.
[Insert Witty Sig Here.]
#8
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)