Crash Of The Titans works on PCSX 0.9.4
Hello and on compatibility list says that Crash of the titans doesn't work.It does work on 0.9.4 with zero gs 0.97.0.Down there is the screenshot in-game and I think that is fully playable with few glitches (shadow and sound glitch) on 0.9.4.And BTW my processor is too slow so don't say how much FPS I got.And scenes are syncronized with sound even if I got 5 fps.


Sponsored links

"playable" means that a beta tester has verified that a game can be played from start to finish on the emulator, without any major issues and regardless of the speed. users reporting that they "think" a game is playable is not enough to change its status Wink

you really should use a newer pcsx2 version, 0.9.4 is quite old already. get either the latest stable 0.9.6 or the latest public beta r1888. chances are that it works fine in the latest beta, but no guarantees of course.
CPU Core [email protected] | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
As you can see on the compatibility list the game was last tested with PCSX2 0.9.6 which is the current supported stable release in which it doesnt work, it's known to have worked on an older version but this becomes irrelevant to the compatibility list as it tries to keep up with the newest release not to establish when it worked.

As zero29 mentioned you should try the newest beta maybe it will work there.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Unforteantly I can not.Because my processor does not support SSE2.I have an really old one.Maybe somebody else?

Users browsing this thread: 1 Guest(s)