Crash after several minutes
Hi, I hope I'm posting this correctly and I'll update with any additional details as needed.

Sadly my PS2 bought the farm a few years ago and I've been using PCSX2 in previous incarnations to replay old RPGs (FFX, .hack, Dragons Quest VIII, etc) from .iso's of my original disks.

Now, the FFX ISO was working fine with 0.9.7 of PCSX2 but I decided it'd be a good idea to upgrade to the newest version. PCSX2 now simply crashes without warning after approximately 20-30 minutes of play. I've tried several ISOs (all RPGs admittedly) and the effect is the same. There is no performance impact, no stuttering, lag, graphical artifacts or anything. The games continue to look perfect right up until the moment it just completely stops responding and throws up the Windows error message 'Program has stopped responding'.

I can't see anything wrong in the log when booting the ISO and would appreciate a little help from anyone who knows any possible way to stop this crash from happening.

PCSX2 1.0.0.r5350 - compiled on Aug 1 2012
Savestate version: 0x9a080000

Host Machine Init:
Operating System = Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 16334 MB
CPU name = Intel® Core™ i7-3770K CPU @ 3.50GHz
Vendor/Model = GenuineIntel (stepping 09)
CPU speed = 3.509 ghz (8 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 7f9ae3bf
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Reserving memory for recompilers...

Loading plugins...
Binding GS: D:\Emulators\PS2\Plugins\gsdx32-avx-r5350.dll
Windows 6.1.7601 (Service Pack 1 1.0)
NVIDIA GeForce GTX 570 (
Binding PAD: D:\Emulators\PS2\Plugins\lilypad-r5350.dll
Binding SPU2: D:\Emulators\PS2\Plugins\spu2-x-r5350.dll
Binding CDVD: D:\Emulators\PS2\Plugins\cdvdGigaherz.dll
Binding USB: D:\Emulators\PS2\Plugins\USBnull.dll
Binding FW: D:\Emulators\PS2\Plugins\FWnull.dll
(GameDB) 9640 games on record (loaded in 116ms)
Binding DEV9: D:\Emulators\PS2\Plugins\DEV9null.dll
Plugins loaded successfully.

HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
NVIDIA GeForce GTX 570 (
Init PAD
Init SPU2
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: D:\Emulators\PS2\Games\Dot Hack Part 1 - Infection.iso
Image type = DVD
Fileparts = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1445376 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\WskOsc\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\WskOsc\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Europe v01.60(04/10/2001) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps


Sponsored links

Sorry for bumping but I've been patient for a reply which hasn't come.

Anyone have any ideas?
tried using other gsdx plugins? (like SSE2)
Just sort of throwing it out there to cover all bases, but have you checked your CPU and GPU temps as you play? Also how old is your PSU and what wattage? Extended load on the system can mean there could be an unstable component, overclock, etc. It may be worth your time to run Prime95 and Intel burn test to see if stability and temps are an issue.
Intel Core i5-8600K @ 4.5 GHz
GeForce GTX 1080 SC2 Stock
ASRock Z370 Taichi LGA 1151 mobo
CORSAIR Vengeance LPX 16GB 2400 DDR4 RAM
SAMSUNG 970 EVO M.2 2280 500GB PCIe SSD
Indigo Xtreme Thermal Interface Material
Phanteks Enthoo Pro ES614P Black Steel Case
EVGA SuperNOVA 750 G2 220-G2-0750-XR PSU
Windows 10 64-bit
If it was a temp issue the whole system would shutdown and not boot until the temps dropped. At least thats what my issue was and flipping the whole system so that the psu was on the bottom seems to have have drop them to acceptable levels to where the system is running fine even when running pcsx2 as my system was shutting down with an older pc game mainly Neverwitnernights 2 but an unstable overclock may be the cause.
Crashing seemingly random after a certain time frame is usually a memory issue. To be safe try using SVN r5460 and work away using that, and report back if the problem still arises.

Try to use a settings preset also. I usually use the safe preset with the mtvu hack enabled, as I don't really need hacks for speed generally with my system, which has the same chip as yours.

Users browsing this thread: 1 Guest(s)