Crash when using hardware graphics (Radeon)

I'm having a problems with crashes when I try to run 0.9.6 with hardware graphics.

My plugins:

AMD X2 4600+
Ati Radeon x1900xt with latest Catalyst drivers (9.2)
I installed the latest DirectX yesterday

I'm using default settings (see picture above).

I've tried Final Fantasy XII (NTSC) and Disgaea (NTSC).
FFXII crashes in the beginning when you've started, seen the CG movie and then read some text... both with ZeroGS and GSdx in hardware mode. Sometimes the whole computer crashes, sometimes the drivers goes in and does a VPU recover (because the graphics device stopped responding).

Disgaea crashes in the beginning after a while during the initial dialog (when the guy wakes up).

Both games works in software mode...

My first guess would be that there is some kind of conflict between PCSX2 and my graphics drivers. But it's odd, I don't really have any problems with any other games / emulators.

My questions are
1. Is anyone else experiencing similar problems?
2. Do you know any good settings to play around with to prevent this?

Thanks in advance.

Sponsored links

Yeah sounds like *really* crappy video card drivers. Since your card is not one of the latest,and usually the latest drivers are aimed at the bleeding edge models,it is probable that the ATI dudes messed something up breaking things in older video cards. My suggestion would be using an older driver and see how it goes
[Image: newsig.jpg]
ATI stopped supporting AGP cards in their drivers LONG ago (If your card is one of the AGP versions). Try using the Omega drivers.
.:Intel Core i7 Extreme 965 OC'ed @ 4Ghz - EVGA X58 SLI - Corsair 6GB @ 1600Mhz 9-9-9-24 - 2xEVGA GTX 285 1GB OC'ed @ 680/1548/1270Mhz in SLI - Dell UltraSharp 24" - Corsair HX1000W PSU - Noctua NH-U12P SE1366 - Antec 900
.OhmyCZ Vertex 250GB SSD 200/160MB/s read/write - Samsung F1 1TB
.:Windows 7 x64
Try with old gsdx first, gsdx.0.1.8 or gsdx.0.1.9. I dont have problem like you after install directx nop.2008 and play with latest gsdx.0.1.14. Ps. My ati driver is 8.12.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
I just tried gsdx 0.1.8 and it's the same, computer crashes. It's PCI-E btw.
I think I'll give Omega Drivers a try. It was a while since I last used them.. otherwise I'll give 8.12 a try.

I'm been a long time time Ati supporter but I'm starting to get annoyed with their driver quality. Previously I had problems with Quake Live, but at least that started working after I installed the 9.2 drivers I have now.

Thanks for your responses Smile

Users browsing this thread: 1 Guest(s)