Hello, I have been using PCSX2 1.6 without issues for quite some time.  Currently have been playing Persona 3 FES with the New Moon Balance patch without incident as well until recently.  Suddenly, the program would just crash and close me back to my desktop whenever I tried open an ISO or ELF file or go into any of the configuration screens.  So I downloaded a new file from the website and copied over my old directory.  I open it up and it starts normally, I select to import my plugins and hit "Next".  A box pops up saying "Applying setting..." and then a few seconds later, the program just crashes again.  Please let me know if I can provide any other information.

Any assistance would be greatly appreciated.

Thanks in advance.

Sponsored links

I used in the past the method of just extracting new builds in PCSX2 folder to replace files and it ended crashing the emu, probably because of old files unneeded because if I used fresh install instead the emulator worked perfectly and some old files weren't there then, so since you seems to had done the same thing my advice would be to first try to make a new install of PCSX2 with the lastest dev builds and see if it works, then if it works copy back your saves to the working fresh install.
As suggested, update to the latest nightly build and copy it into a separate folder. The new builds no longer use plugins that you have to import over.
Windows 11 64 bit OS
Intel Core i7-10700
Geforce RTX 2060 6GB
Thank you guys! I downloaded pcsx2-v1.7.2564-windows-x86 and it works! Even got my wireless controller functioning. Much appreciated! Now to finally finish my New Game+ run.

Users browsing this thread: 1 Guest(s)