Crashing on startup
Hi, I'm a new member of the community, and I'd like to ask for some assistance.

I'm currently unable to load any of my games (yes, I do own them) on startup, everytime I do I get the same error. As far as I'm concerned I adjusted settings to near low or recommended following the website's guide, even though I believe my laptop should be able to run at higher settings. Tried with different games as well to no avail.

emulog included:

PCSX2 0.9.7.r3876 (modded) - compiled on Oct 5 2010
Savestate version: 0x8b4c0000

x86-32 Init:
CPU vendor name = GenuineIntel
FamilyID = a
x86Family = Intel® Core™2 Quad CPU Q9000 @ 2.00GHz
CPU speed = 1.993 ghz
Cores = 4 physical [4 logical]
x86PType = Standard OEM
x86Flags = bfebfbff 0c08e3fd
x86EFlags = 20100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1

Allocating memory for recompilers...

Loading plugins...
Binding GS : F:\Games\PCSX2 0.9.7\Plugins\gsdx-sse2-r3878.dll
Windows 5.1.2600 (Service Pack 3 3.0)
NVIDIA GeForce GTX 260M (
Binding PAD : F:\Games\PCSX2 0.9.7\Plugins\lilypad-r3878.dll
Binding SPU2 : F:\Games\PCSX2 0.9.7\Plugins\spu2-x-r3878.dll
Binding CDVD : F:\Games\PCSX2 0.9.7\Plugins\cdvdGigaherz.dll
Binding USB : F:\Games\PCSX2 0.9.7\Plugins\USBnull.dll
Binding FW : F:\Games\PCSX2 0.9.7\Plugins\FWnull.dll
Binding DEV9 : F:\Games\PCSX2 0.9.7\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 8934 games on record (loaded in 547ms)
HLE Warning: ELF does not have a path!!

Initializing plugins...
Init GS
Windows 5.1.2600 (Service Pack 3 3.0)
NVIDIA GeForce GTX 260M (
Init PAD
Init SPU2
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Allocating memory for the PS2 virtual machine...
Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
read error in _isoReadBlock.
read error in _isoReadBlock.
read error in _isoReadBlock.
detected blocksize = 2448
isoOpen(Audio CD): E:\IOPRP271.IMG ok.
The iso has 111 blocks (size 2448).
The iso offset is 0, and the block offset is 0.
5:08:59 PM: Fatal error: The previous message repeated 2384592964 times.
5:08:59 PM: Program aborted.
Closing plugins...
Closing SPU2
Closing PAD
Closing GS
Forced software switch enabled.
Plugins closed successfully.
Shutting down plugins...
Shutdown DEV9
Shutdown FW
Shutdown USB
Shutdown CDVD
Shutdown SPU2
Shutdown PAD
Shutdown GS
Plugins shutdown successfully.

The game in question loaded here was Star Ocean 3, with the VU Add hack enabled. Any help/advice would be appreciated, thanks.

Sponsored links

looks like you're trying to launch the .img file inside your PS2 disc.

dump your DVD into an ISO using a soft like imgburn, then load the iso file just the same way you tried
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Ah.. must have missed that. Didn't know you couldn't load directly from the DVD, thanks!
you can, but you must use gigaherzcdvd or peops cdvd to use the dvd directly. However running from ISO is much quicker and you can keep your discs safe Smile
[Image: ref-sig-anim.gif]

Just to avoid a possible headache ahead. If using the "Iso" option under the "CDVD" menu, the actual ISO must be selected from the "Browse" option under the "Iso Selector" at the same menu AND NOT mounted anywhere else, not in a plugin and not in a virtual driver (like alcohol, daemon, etc) and not have the physical disk mounted too.

If for some reason you want to use a CDVD plugin, so the option must be "Plugin" and not "Iso" in the CDVD menu and the image must be mounted in the respective plugin.

Whatever the chosen way, the actual game startup is done under the "System" menu "Boot CDVD (Fast)" option.

If "Iso" is selected and the image is mounted somewhere else (like in a plugin or virtual device)... the emulator will become confused and crash (unless it was reviewed on the last release, what remember me I must actualize my version).
Imagination is where we are truly real

Users browsing this thread: 1 Guest(s)