Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Crop FMV instead of stretching
#1
I'm currently playing Tomb Raider: Angel of Darkness. By changing the aspect ratio in both the BIOS and the window settings, I managed to make the game play at a 16:9 ratio but this isn't exactly the case with FMVs

The FMVs are already recorded in a 16:9 aspect ratio but letterboxed to fit a 4:3 screen. So even when I play on a 4:3 aspect ratio on my 1080p screen, I see black bars at the top and bottom and the video is at the very center of the screen.

When I play it at 16:9, I still see black bars at the top and bottom but it's just stretched out horizontally. So what's really happening is that a 16:9 video is stretched out and the resulting aspect ratio appears closer to 2.4:1.

I know that PCSX2 1.5 has the option to switch to 4:3 only for the FMVs, which is better than having them stretched out but it still uses just a portion of the screen. Is there a way to crop the black bars instead? Or any other way to make it fit the screen without it being stretched out?
Reply

Sponsored links

#2
Are you by chance using a widescreen patch? Even if you haven't knowingly added one, there may be one in the widescreen patch archive that ships with PCSX2, and these can often cause these sort of oddities since they are making games do things they weren't intended to. Try disabling them in the first drop down menu beneath the boot options, then reboot the game and try again, without using savestates.
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ RGB Series, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070Ti FTW2 (8 GB)

Oh yeah Red Pandas are cool too.

Reply
#3
(07-12-2018, 01:53 PM)pandubz Wrote: Are you by chance using a widescreen patch? Even if you haven't knowingly added one, there may be one in the widescreen patch archive that ships with PCSX2, and these can often cause these sort of oddities since they are making games do things they weren't intended to. Try disabling them in the first drop down menu beneath the boot options, then reboot the game and try again, without using savestates.


I have both cheats and widescreen patches disabled. I know that the cutscene already has black bars at the top, and the reason it's being stretched out is because PCSX2 always does that when you change the aspect ratio to 16:9

What's happening is actually standard PCSX2 behavior and it even says so on the official configuration guide. My question was if there's a way to prevent that.
Reply
#4
Nevermind I found a way. A quick look at the Hotkeys page tells you how to stretch the video output vertically and also reset it. Not the most ideal solution, but it works.
Reply
#5
Yeah I don't know of any codes to crop FMVs like that. You could try asking in the WIdescreen patch thread and see if someone could help you figure that out otherwise you are going to be stuck with the bars in 4:3.
Reply




Users browsing this thread: 1 Guest(s)