DQ 8 King Pavan - no cutscene
I'm not sure if this is a known bug or not, but in two different save games I can get to Ascantha, get Emma's cutscene saying to come back at night but when I do I can't talk to King Pavan and continue my game. Both saves he just sits there. I am running the current release of PCSX2 and am running the PS2 game in my dvd drive. If I try going to Emma's grandma she just repeats that Emma is working and doesn't send me to the hill. Time does not pass at the hill to let me get the harp.
I have tried running with not speedhacks on the second game and making sure not to end dialog using the triangle button which I found breaks the game if you hit it for Kaldarasha's daughter in the start of the game. Someone please help. Sad

Sponsored links

Since you got the first scene with Emma, make it nightime. Using the inn to rest until night is fine. Go back to the castle. The king is not helpful so rummage around the castle and bump into Emma again (yep, twice) before going to grandma's place (and subsequently the next plot point of the game).

This game is completely playable from beginning to end, including post game. The only strange part is needing to use extra clamp mode to go inside Kalderasha's house at the start of the game.
Unfortunately I never get the king to even say anything at night and Emma is not in the castle. When I run everywhere inside and then head out (after resting until evening in the inn) she is always found in the church repeating the same line as in the morning. I have tried talking to everyone inside multiple times both at night and in the morning. I can post my mem card after work today if that helps.
I even followed along the youtube walkthrough to make sure I wasn't doing something dumb.

I did find a bug though in the beginning of the game when Kadarasha's daughter asks you to find the crystal ball. If you speed through the dialog using the triangle key it will auto-pick no, and then I could not talk to her again to get the quest. King Trode kept sending me inside to say yes and the daughter would not speak with me any more. It seems much like that, but I did not use triangle for the Emma/Adviser cutscene and there was no will you help type question.

tl/dr: I may be dumb so should I upload my save file to be looked at?
Go ahead and upload your save. I have NTSC version of DQ8.
Mem card 1 is the second run through, ending at the river chapel. Mem card 2 is the original one saved in the middle of the problem. I used speed hacks for the first run through, but not for the second.
I have also attached the cheats I am using.
I am using the current stable release of pcsx2 and tried both 1.60 and 2.00 bios versions.

Attached Files
.7z   memcards.7z (Size: 26,77 KB / Downloads: 124)
.pnach   F4715852.pnach (Size: 553 bytes / Downloads: 260)
OK good news. I think I know what your problem was. It could have been one or two things.

First, when I went into the castle the king was not at his throne. It must have turned to daytime while in the castle so it caused the NPCs to change their location. I could prove this by the fact that I had to go to the king's locked chamber and it was light outside. So I immediately went back to the inn and rested till nightime. Then I went back to the palace and talked to the king crying at the throne room. Then I bumped into Emma to trigger the next plot point to see her grandma.

I zoomed to Riverside Chapel and noticed you did not spend the night there to get the backstory of Angelo and Marcello. That could have played a role in the problem as well. Once I got through that I went to the house across the bridge and talked to the grandma, which essentially she leads you to the Wisher's Peak plot point.

Nothing wrong with PCSX2. I used default values and pnach file. This game tolerates pretty much everything, speedhacks and all. It is easy to miss a cutscene in this game. And it's easy to get stuck because of it. Hope this helped! Smile
Ok I am beginning to think something is very wrong with my pc. I tried it again, this time going to the riverside chaple to get the cut scene first. Then back to the king. Still no go. The I exited pcsx2 and reopened it and disable the hardware hacks (I was using the wild arms one for the dialog and the skipdraw 2 for the flashbacks). Loaded the save, went into castle, talked to emma, stayed till evening at the inn, went back to the king, and STILL NOT TALKING TO ME!!! arg! Then I looked online for how to record it. Fraps limited me to 30 seconds but I found out to try hitting f12 in pcsx2 for it to record. I did this, loaded the game, went into the castle, talked to emma, stayed in the inn till evening, went back to the king and this time he talked to me. I did it the exact same way as the previous three attempts tonight but it worked when I used the WMVideo 9 codec to try recording it. I hit 12 to stop recording and saved, and then found it only recorded the audio, and not video. Any idea on what could be causing it? I have a Nvidia 660 ti, latest drivers, windows 7 64, steam keeps updating DX, and I tried it with the SSSE3, SSE4, and SSE2 versions of the GS and both DX9 and DX11 versions. Why on earth would recording it fix the unable to target the king to talk issue?
Sigh, if my GF didn't watch me try it at least 10 times I would doubt my sanity.
Thanks for your help, but I am very curious what on earth is going on.
Please post a screenshot or something showing what happens when you try to talk to the king at night. I am not sure what you mean by king not talking to you.

He should be crying on the throne facing the chair. After that you are supposed to go down the stairs and bump into Emma.

When I tested your memory card I used SVN version, no speedhacks, clamp modes to default. nothing fancy. This game should be fine on pcsx2. I have played it from start to finish in the past. Make sure also to disable cheats for this purpose to prevent any potential effects on the game's internal flags.
I'm not trying to be difficult. I literally mean that he will not initiate dialog with me unless I start recording it right after launching PCSX2. Here are three screen shots.
In the first screen shot I have run all around him while hitting the x key trying to get him to say he misses his wife. He just sits there. Exited PCSX2, reloaded, started the video capture and BOOM, he learns to talk.
Software currently running on my computer is comodo firewall, mse, nvidia's control panel, and razer's mouse software, and firefox in the background. I'm banging my head on the wall trying to figure out why this is happening. Thankfully once I started recording it I can move on, so that's what I will do.

Attached Files Thumbnail(s)
That's definitely one strange bug you have there. I glad you found a workaround. I have no idea why it's doing that. I have attached the memcards you gave to me. I got past the area I mentioned in my above post. Your next stop is Wisher's Peak. That's if you need or choose to use this method.

Attached Files
.rar   memcard-dq8-past-stuck-area.rar (Size: 66,96 KB / Downloads: 91)

Users browsing this thread: 1 Guest(s)