DS3 Controller Setup issues
OMFG... I must have read every guide out there and kept running into problems. The usual problem is I can't do a step because it's simply not an option for me.

I've tried lilypad, libusb, SSSPSX, and Nuvee.
Can't seem to get them to work or even configure them. (Yes I moved the files to the plugin folder)
Do I have to use winrar or does 7zip work? winrar wasn't working so I started using 7zip... no luck.
7zip doesn't seem to work. I'll extract it but then when I click on it it opens in 7zip and I can't really do anything.

The PSX2 does work. The game does start, but I can't use my controller.

I had a DS3 Tool (motion joy?) that read my controller when trying to use it for PSX1, but I couldn't use it for that emu either.

I had motion joy but read that it was bad so I uninstalled it, but still nothing seems to work.

Could someone PLEASE help me step-by-step?
Feel free to send me a link to a guide (that I attempted previously or not), and i'll tell you how far I get.

Sponsored links

First, do not download other plugins, everything you will need is already included in the PCSX2 1.0.0 package.
Also uninstall/delete all the motionjoy crap and whatnot.
After you do a new clean install of PCSX2 1.0.0, go here: http://forums.pcsx2.net/Thread-XInput-Wr...#pid288628

Download the attachment at the end of the post: SCP-DS3-Driver-Package-
Then follow the instructions in the same post named: New Install

After you're done your DS3 will be recognized by windows as an Xbox360 controller, so configure lilypad, enable Xinput in the first screen and normally assign keys in Pad 1
[Image: newsig.jpg]
Thank you for the reply.
Unfortunately I can't do one of the steps. (big surprise)
5. Run ScpDriver.exe. - does not exist in the folder I downloaded

I uninstalled my PSX2 and reinstalled a fresh one.
I then downloaded the attachment 'SCP-DS3-Driver-Package-' and created a new folder within 'Program files' like it instructs.

Open that folder and all I have is another folder named ScpServer, which opens to an empty bin folder, which opens to a system folder, which has 2 files named BthWinUsb (one is 12kb the other is 7kb)

... wtf?!

Edit: so I downloaded SCP-DS3-Driver-Package- and that actually has the files I need! Ohmy Lets see how this works out... but first i'm going to sleep. Will post in the next 24 hours.
Yeah that was my bad, that file has updated bluetooth compatibility but the main program was the second one you got
[Image: newsig.jpg]
Okay... after downloading the driver package and moving it into my program files I ran the installer and installed it and restarted my computer.

Still doesn't work. You told me to configure lilypad, but I can't seem to do that.
It is grayed out as a plugin.

My Controller pad settings are:
Keyboard API
x Windows messaging

Game Device APIs
x XInput

Mouse API
x Disable

Pad 1 Dualshock 2 0 Bindings
Pad 2 Dualshock 2 0 Bindings
Port multitap is not checked

Device Diagnostics
WM Keyboard

That's most of it. (x = only thing selected)

When I go to Pad 1, there's no device there.

I'll try these steps tomorrow.
"Important - make sure your Bluetooth dongle and DS3(s) are plugged in via USB before running ScpDriver.exe. Make sure you have the latest DirectX redist installed and the latest X360 drivers available.
The inbox X360 drivers that ship with Windows 7 are outdated and may cause stability issues - it is highly recommended that you install the Microsoft Xbox 360 Accessories software from this link before installing the drivers."

Also, my controller would stay connected (lights on) 1, 2, 3, then 4 Or staying on 1.
When I was trying to do this on my own, I was able to get a controller into the Pad 1 Device tab.
After doing this from scratch and uninstalling motionjoy, the light turns off shortly after blinking and stuff.

Users browsing this thread: 1 Guest(s)