Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dark Cloud frame rate problems
#1
Hey. So I'm trying to play Dark Cloud (the first one), but the frame rate is always dropping from 100% (60fps) to around 60-70%. And since the mechanics of this game in particular are very sensitive to the frame rate, the game gets way too tedious to play with this lag. It was working just fine when I was playing through the Divine Beast Cave, but now I've started the Wise Owl Forest and the problem keeps persisting; it could be because the background of the forest is graphically more detailed than the first cave, as the lag only comes once I enter the forest and not in any of the villages. 

Here are my software and hardware specs:

MSI GS63VR Stealth Pro laptop with Windows 10 OS (64 bit)
Intel 7th Gen Core i7-7700HQ
NVIDIA's Geforce GTX 1060
RAM: 16GB DDR4-2400MHz
version 1.4.0-64 bit of course- of PCSX2 (all emulation settings are set to default for the sake of simplicity in this thread, I've tried configuring them myself and no luck); All my games are ISO's downloaded online, not from disks
Direct 3D11 software configuration on the GS settings of the emulator, so far it looks to be the best option.

All my other ISO's work just fine, it's only Dark Cloud. So I imagine there are some things I need to configure to make it work better. And I'm sure the specs above are beyond the capabilities required for both the emulator and the game. Nothing I looked up online helped-google, the official Dark Cloud page on the PCSX2 wiki, or this site. So any help would be greatly appreciated.

Sponsored links

#2
Quote:All my games are ISO's downloaded online, not from disks
Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)