Devil May Cry black screen after intro.
My issue: The game freezes after Trish tells Dante who she is then talks about how some guy is trying to open the portal to the Underworld on Milea Island(sp?) approx. 3mins in.

My PCSX2: I'm currently running PCSX2 Oct 2010 beta with ALL default settings on Windows XP(GSDX9)

My attempts at fixing it: I tried giving it some VU cycle stealing along with one of the skip MPEG hacks on GSdx in case there was a video it is black screening on. I tried switching between Software/Hardware mode. I also tried an older version of GSDX9.

I'm having no problem with speeds or such like all the other posts I have searched and I found nothing about the issue I am having.

If I'm unclear about the part it freezes at then, sorry; I've owned this game for quite some time but never played it before.

Thanks for any help someone can provide.Blink

Edit: I believe an easy fix might be if someone could give me a save file soon as you're able to save so I can just skip past this black screen part!

Attached Files Thumbnail(s)

Sponsored links

Try checking the OPH flag hack and/or the EE timing hack under game fixes. DMC1 is known to be very timing sensitive that's why it keeps breaking/working every time
[Image: newsig.jpg]
Thank you! The timing hack fixed it.
I'm experiencing the same problem. I've already checked the EE Time hack but it still gives me a black screen. Exactly the same event. I've already tried other GSD but it still gives me the blank screen.

Can anyone help me ? I just recently installed PCSX2 and I've been dying to play DMC for years T_T.
You can try with older PCSX2 versions, like the 0.9.6 stable.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Thanks it's working now. It seems DMC is not stable in 0.9.7 version of the PCSX2. Got me worried that i wouldn't be able to play DMC but its all good now. Cheers !Biggrin
(12-11-2010, 09:47 AM)Shadow Lady Wrote: You can try with older PCSX2 versions, like the 0.9.6 stable.

Okay, I did this (after the gamefixes didn't work for 0.9.7 But in the opening sequence all the audio is off, keeps skipping ahead so it goes something like this "Devil may cr....damn now pas....whoa slow down la..." and so on. any idea how to fix this?
Motherboard: GIGABYTE GA-790XTA-UD4
CPU: AMD Phenom™ II X4 965 Processor (4 CPUs), ~3.4GHz
GPU: Radeon HD 5830 (1GB Memory, 256 bit)

Users browsing this thread: 1 Guest(s)