Devil May Cry pal crashes
Hi Smile I was wondering if there was a solution to DMC crashing on the PAL version? When I boot the game, its fine until new game is selected, and then it freezes before the Sparda scene.
I've tried enabling the skip MPEG hack, but when it gets past the CAPCOM logo, it says: "sceMpegIsEnd pattern found! Recompiling skip video fix..." And doesnt do anything.
Speedhacks are off, any other patches are off, Ive tried PCSX2 0.9.6, 0.9.7 and 0.9.8 but the result is the same.
Ive searched around and enabling EE cyclerate, EE timing hack or any other fixes don't work. Everything I've tried has had the same effect, nothing.
Ive tried using GSDX and ZeroGS, software and hardware mode, still doesn't work.
Is there any way I can get this game to run? Thanks for any help Smile

Sponsored links

This is fixed with current head SPU2-X (it has nothing to do with anything but SPU2). Look out for the next release or grab the plugin from the SVN snapshots thread.
Thanks for the reply. Smile
Ive taken the SPU2 plugin from the latest SVN (r4777) but it still doesn't work. Are there any specific settings I need to enable or anything like that?
Oh, sorry, until a new game is selected? I don't know about that problem Smile
Try enabling/disabling the "EE cycle rate" speedhack, I remember it used to do something for Devil May Cry.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Please make sure to use the latest PCSX2 and SPU2-X SVN versions.
The game works fine with that in all tested settings (except SPU2-X mixing set to async, so don't do that Tongue2).
Thanks for the replies Smile
Shadow Lady - Ive tired turning it on, but it hasn't had any success.
Rama - I've tried the latest SVN r4779 from the site, using the latest SPU2-X version without any speedhacks or anything, but it still doesn't reach the FMV, just freezes. Maybe it's my game? I'll try it on my PS2 when I can to see if the disc is alright.
Do you still have the mpeg skip gamefix enabled? Please disable, if so.
I think I've figured it out... When running it directly from the DVD in the drive, it works fine, but when it's the ISO I got from it, it doesn't work? I'll try ripping the ISO again, see if it works.
In that case make sure to do the ISO with ImgBurn.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64

Users browsing this thread: 1 Guest(s)