Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Digimon World 4 Start Button
#1
So... yeah. 1.6/ 1.7.- are great, but after upgrading from 1.5.x, my Iso of Digimon world 4... either of them, for that matter (USA and EU), no longer have a functioning start button. Just the start button. And it's super weird because the start button works on Devil May Cry 3 just fine. Any idea what could have caused this?
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Uh... k then.

Code:
PCSX2 1.7.0-20210125183347 - compiled on Jan 26 2021
Savestate version: 0x9a180000
Host Machine Init:
Operating System =  Microsoft Windows 10 Home (build 19042), 64-bit
Physical RAM    =  12238 MB
CPU name        =  Intel(R) Core(TM) i5-4460  CPU @ 3.20GHz
Vendor/Model    =  GenuineIntel (stepping 03)
CPU speed        =  3.192 ghz (4 logical threads)
x86PType        =  Standard OEM
x86Flags        =  bfebfbff 7ffafbbf
x86EFlags        =  2c100000
x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA
Reserving memory for recompilers...
Loading plugins from C:\Emus\PCSX2\plugins...
Bound  GS: GSdx32-AVX2.dll [GSdx 20210125183347 (MSVC 19.26 AVX2/AVX2) 1.2.0]
Plugins loaded successfully.
[GameDB] 10326 games on record (loaded in 385ms)
HLE Notice: ELF does not have a path.
Initializing plugins...
Init GS
Plugins initialized successfully.
Patches: No CRC found, using 00000000 instead.
isoFile open ok: C:\Emus\pcsx2-v1.5.X\Digimon World 4 (USA).iso
Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (707472 sectors)
Opening plugins...
Opening GS
Current Renderer: Direct3D 11
GSdx Lookup CRC:00000000
McdSlot 0 [File]: C:\Emus\pcsx2-v1.5.X\memcards\Mcd001.ps2
GSdx Lookup CRC:00000000
McdSlot 1 [File]: C:\Emus\pcsx2-v1.5.X\memcards\Mcd002.ps2
Plugins opened successfully.
48000 SampleRate:
EE/iR5900-32 Recompiler Reset
Bios Found: USA    v01.60(07/02/2002)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
# Initialize memory (rev:3.63, ctm:196Mhz, cpuclk:147Mhz detected)
PlayStation 2 ======== Hard reset boot
ROMGEN=2002-0207, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
<20020207-164243,ROMconf,PS20160AC20020207.bin:11552>
# Total accessable memory size: 32 MB (B:2:8:0) (363:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.
EE DECI2 Manager version 0.06 Feb  7 2002 16:41:20
  CPUID=2e20, BoardID=0, ROMGEN=2002-0207, 32M
Patches: No CRC found, using 00000000 instead.
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_208.36;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
found 0 symbols
ELF (cdrom0:\SLUS_208.36;1) Game CRC = 0xB871C1D0, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_208.36;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLUS_208.36;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SLUS_208.36;1
0 00100000 00454b00 ......................................................................
Loaded, cdrom0:¥SLUS_208.36;1
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Elf entry point @ 0x00100008 about to get recompiled. Load patches first.
[GameDB] Searching for 'slus-20836' in GameDB
[GameDB] Found 'slus-20836' in GameDB
[GameDB] Searching for patch with CRC 'b871c1d0'
[GameDB] No CRC-specific patch or default patch found
[GameDB] Searching for 'slus-20836' in GameDB
[GameDB] Found 'slus-20836' in GameDB
[GameDB] Searching for patch with CRC 'b871c1d0'
[GameDB] No CRC-specific patch or default patch found
Get Reboot Request From EE
ROM directory not found
GSdx Lookup CRC:B871C1D0
GSdx Lookup CRC:B871C1D0
PlayStation 2 ======== Update rebooting..
PlayStation 2 ======== Update reboot complete
cdvdman Init
IOP Realtime Kernel Ver. 2.2
    Copyright 1999-2002 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadmodule: fname cdrom0:¥MODULES¥LIBSD.IRX;1 args 0 arg
loadmodule: id 25, ret 0
loadmodule: fname cdrom0:¥MODULES¥IGFILEIO.IRX;1 args 0 arg
Intrinsic Alchemy File IO module (02/11/26)
loadmodule: id 26, ret 0
Requested format: color=default, alpha=default, depth=default, stencil=default
Intrinsic Alchemy FileIO Initializing cddvd device...
Intrinsic Alchemy FileIO DVDROM Initialized
Error searching file (¥DRIVERS.Ini;1)
Disk error code= 0x00000000
Error searching file (¥..¥DRIVERS.Ini;1)
Disk error code= 0x00000000
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.93 fps
Alchemy display 640x448 NTSC (color 32, depth 16)
Base texture address = 0x2bc0
GS csr.id = 85, csr.rev = 27
watchdog started
Two read circuit enabled
Actual format: color=32, alpha=0, depth=16, stencil=0
loadmodule: fname cdrom0:¥MODULES¥SIO2MAN.IRX;1 args 0 arg
loadmodule: id 27, ret 0
loadmodule: fname cdrom0:¥MODULES¥PADMAN.IRX;1 args 0 arg
loadmodule: id 28, ret 0
loadmodule: fname cdrom0:¥MODULES¥MTAPMAN.IRX;1 args 0 arg
loadmodule: id 29, ret 0
loadmodule: fname cdrom0:¥MODULES¥SDRDRV.IRX;1 args 0 arg
SDR driver version 4.0.1 (C) SCEI
Exit rsd_main
loadmodule: id 30, ret 2
loadmodule: fname cdrom0:¥MODULES¥CRI_ADXI.IRX;1 args 19 arg sdinit=0
CRI ADX Driver Ver.9.31s281(Oct  6 2004 11:47:50)
CRI ADX Driver : sceSdInit Call = 0
CRI ADX Driver : Main Thread Priority = 39
CRI ADX Driver : PSM Thread Priority  = 39
CRI ADX Driver : DTX Thread Priority  = 48
CRI ADX Driver : SPU CORE Number = 1
loadmodule: id 31, ret 2
loadmodule: fname cdrom0:¥MODULES¥SNDFI.IRX;1 args 0 arg
SNDF Driver Ver 2.09c(Oct  4 2004 20:46:28)
loadmodule: id 32, ret 0
Unknown device 'host'
Known devices are  cdrom:(CD-ROM )  rom:(ROM/Flash)  tty:(CONSOLE)
SRD: sceOpen error = -19
HTCI: Can't read filelist file.(cdvd.fic)
DVCI: "NDMW.IGB" found.
DVCI: "AREA.AFS" found.
DVCI: "NDMW.AFS" found.
DVCI: Total 3 files.
PS2RNA: sceSifAllocIopHeap(266304) ret=0x000c7e00
PS2RNA: sceSifAllocIopHeap(2256) ret=0x00108f00
PS2RNA: sceSifAllocIopHeap(16448) ret=0x00109800
loadmodule: fname cdrom0:¥MODULES¥MCMAN.IRX;1 args 0 arg
loadmodule: id 33, ret 2
loadmodule: fname cdrom0:¥MODULES¥MCSERV.IRX;1 args 0 arg
loadmodule: id 34, ret 2
Reply
#4
can you pelase show your lilypad settings ?
What kind of controller do you have ?

edit : did you actually disable MTVU speedhack ?
Edit 2 : try using fastboot intead of full boot
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
Currently am using Fastboot. And I did diable the multicore Speedhack. I am currently using a somewhat damaged PS3 controller, but I'm doubtful it's a hardware issue as the start button registers just fine on DMC3 and on the joypad config.


Attached Files Thumbnail(s)
   
Reply
#6
A DS3 ? how are you wrapping it ? using steam ? Ryochan's ds4windows ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
Thankfully, neither. While it did take forever for it to get naturally picked up by the updates to the lilypad plugin, Lilypad does recognize my Snakebyte DS3 without a wrapper. Even with how damaged it is.
Reply
#8
try disabling dinput

alternately, it could be a good idea to use a wrapper, then
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
So, i do need to clarify this slightly. My start button works in Digimon World 4 for everything EXCEPT bringing up the start menu/ pause screen once i'm in the actual world. My snakebyte is currently only being read by the DirectInput settings.
Reply
#10
then disable xinput.
because your lilypad settings show some xinput devices next to your dx device.
i think sometimes it messes up
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)