Dinput Wrapper for SCP Driver
This program uses the SCPproxy class in the SCP driver (and was adapted from the GTA mapper from SCP to map the dualshock controls to feed inputs to an vJoy joystick.

This means that you can use the controller in dinput only games without the issue of joined trigger axis.

1. ScpServer Reloaded v1.6.238.16010 or newer
2. vJoy 2.1.6
3. Administrator rights on your PC.

Note: This program assumes that it's the only program using vJoy. it will automatically configure vJoy resulting in any previous configurations being overwritten

Install ScpReloaded and vJoy
Extract the contents of 7z to any directory.

The program has a mapping pre-loaded.

If you want to change the mapping, select "Load Config"

If you want custom mapping to be loaded by default, name a config file "Default_vjConfig.txt" and put the file in the same directory as "ScpPad2vJoy.exe"


Attached Files
.7z   vJConfigs.7z (Size: 1,8 KB / Downloads: 3.956)
.7z   SCPPad2Vjoy - V1.6.7z (Size: 191,89 KB / Downloads: 3.780)

Sponsored links

I can't get this to work—no games respond to the controller while running SCPPad2Key. Under Devices and Printers, it says that the Xbox 360 Controller needs troubleshooting.

I followed these steps:
Successfully installed SCP driver package under Windows 7. Tested it; works as Xinput.
Installed vJoy 2.04 from the link
Extracted the contents of to the bin folder to the SCP driver install directory.

Whenever I run SCPPad2Key.exe, even after restarting Windows, I click Start and it just disables my controller. What am I doing wrong? Does it matter that it shows a PS3 Controller AND an Xbox Controller in Devices and Printers even when I'm not running this? I only actually have the DS3.
Quote:Xbox 360 Controller needs troubleshooting
The program disables the original Xinput dinput driver when started to prevent any games from getting confused (but results in this message), the program should be re-enabled it when you hit stop / exit the program, (troubleshoot will be able to correct this if the program failed to do this).

Does the controller work in the "Set up USB game controllers" (and does it show up as vJoy when running)

When started, does "Vjoy_raw_device_00" appear in Devices and Printers?
Makes sense. It does show up in "Set up USB game controllers" and the buttons are detected by that. Maybe it's the games I'm trying to play— Tomb Raider II and Final Fantasy XI. Tomb Raider II does detect a vJoy Device as a game controller, though.

Edit: I have no idea what I did, but it works now. Thanks for reading!
...I just tried this to finally fix my FFXI problem.

IT LIVES! Now I can finally use my DS3 with FFXI as long as I run this Laugh The only really minor problem is the vibration function gets disabled, but I haven't had vibrate working in FFXI for years with other controllers, so I'll deal.
Awesome, finally I can use the triggers for buttons without triggering z-axis or losing other buttons. Is it possible to map the PS button in this tool, or could that be added? I assume the SCP driver is capable because the D3Mapper maps it to the ESC keyboard key, and I can always use one more button! In any case, thank you.
@maryadavies Vjoy doesn't support vibration yet so that is expected

@Splice1138 I don't know why I didn't add support for the PS button, must of overlooked that

V1.1 will add support for mapping the PS button and it will bound by default.
I have this error when clicking start. My OS is w7 32bit.

Attached Files Thumbnail(s)
The wrapper used a 64bit dll (vJoyInterface.dll)

I've attached a version that uses the 32bit dll, can you please test to see if it works.

Edit: now avalible in the OP
Nice. That does it.
I don't have to use Xpadder anymore. tnx

Users browsing this thread: 1 Guest(s)