Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Direct3D and OpenGL issues after anniversary edition
#1
Hi, I have a weird problem with pcsx2.
I'm playing PS2 games with pcsx2 since 2014 with no problem at all with almost all my collection. I update frequently and my problems begin with the Windows 10 anniversary edition.

Fist, my PC: Windows 10 fully updated, i7-4820K, Geforce 770 and 16 GB. I know the GPU it's a little bit dated but it runs most of the modern games without any problems. Of course video card drivers updated.

With the last build I have two main issues:

1- Direct3D mode. I usually use this mode (Direct3D11) that used to work flawlessly... I have just one very weird problem; it has random slowdowns in fullscreen mode. When the game it's in fullscreen randomly the FPS drop about 70%, maybe a few seconds, maybe until I do something. If I press the "windows" button the game just run at 100%. If I have the task manager opened above pcsx2 to check the GPU performance the game doesn't drop any fps. So it has random slowdowns ONLY in fullscreen mode with no other application above. I tried activating the "Game mode" from Windows 10 but nothing. Weird.

2- OpenGL mode. I don't know why the videos just crash the application. The video starts, showing a lot of graphical issues and 90% pcsx2 crashes.

I tried almost every option in the config with no luck.

Nvidia drivers? Windows 10 anniversary drivers? Both?

Please help me!

Thanks regards!
Reply

Sponsored links

#2
What's your PCSX2 version?
Reply
#3
(01-13-2018, 02:41 AM)MetisC Wrote: Hi, I have a weird problem with pcsx2.
I'm playing PS2 games with pcsx2 since 2014 with no problem at all with almost all my collection. I update frequently and my problems begin with the Windows 10 anniversary edition.

Fist, my PC: Windows 10 fully updated, i7-4820K, Geforce 770 and 16 GB. I know the GPU it's a little bit dated but it runs most of the modern games without any problems. Of course video card drivers updated.

With the last build I have two main issues:

1- Direct3D mode. I usually use this mode (Direct3D11) that used to work flawlessly... I have just one very weird problem; it has random slowdowns in fullscreen mode. When the game it's in fullscreen randomly the FPS drop about 70%, maybe a few seconds, maybe until I do something. If I press the "windows" button the game just run at 100%. If I have the task manager opened above pcsx2 to check the GPU performance the game doesn't drop any fps. So it has random slowdowns ONLY in fullscreen mode with no other application above. I tried activating the "Game mode" from Windows 10 but nothing. Weird.

2- OpenGL mode. I don't know why the videos just crash the application. The video starts, showing a lot of graphical issues and 90% pcsx2 crashes.

I tried almost every option in the config with no luck.

Nvidia drivers? Windows 10 anniversary drivers? Both?

Please help me!

Thanks regards!
Avoid the latest windows 10 update. I too have problem with the latest windows 10 update with pcsx2 refuse to run.
CPU : I7 6700 3.4 Ghz
GPU : Gigabyte Geforce GTX 1050 TI
SPU : Realtek High Definition Audio
RAM : 16 GB
Os : Windows 10 64 Bit
Emulator : PCSX2 1.5 
Reply
#4
I tried the 1.5 and 1.4 and still there are slowdown in fullscreen in both versions.
That's why I think maybe it's something related to anniversary edition or nvidia drivers.
Reply
#5
probrably the windows update drivers...did you installed the motherboard drivers from the DVD includes in the box??
and i would prefer nvidia drivers...
and also the SPU-X settings must be in Interpolation:Cubic and Modules:directsound
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#6
Related maybe.
https://github.com/PCSX2/pcsx2/issues/2117
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#7
What GSdx settings are you using? Also, don't use 1.4.0, just keep using the 1.5.0 dev builds.
Reply
#8
How you ended up with anniversary edition? is it an update from previous version of win10 or completely new system for you? I merely ask if the actualization to anniversary made a problem?

Anniversary is not the last version, im on newer creators update, but there is also even newer fall creators update. Consider actualization.

And my nephew had intel g4600 with gtx 780 and win10 was slow, like unresponsivned, but when card was taken out, system behaviour was lightning fast. I conclude such old cards are not best tandem with such new system. Gpu drivers are in working state but not optimal.
Reply
#9
I did a few more tests and still nothing.

First I want to apologize, isn't Windows Anniversary update. All my problems began after Falls Creator update.

For all tests I'm using 1.5 version. I'm using GSdx 20180112142120 (the one that says "SSE4.1"). It seems that the slowdown appears with every Direct3D plugin, even the old ones, in fullscreen mode.

I tried messing with audio configuration and no change.

EDIT: In Direct3D there are slowdowns even in software mode.
Reply
#10
(01-13-2018, 11:43 AM)MetisC Wrote: I did a few more tests and still nothing.

First I want to apologize, isn't Windows Anniversary update. All my problems began after Falls Creator update.

For all tests I'm using 1.5 version. I'm using GSdx 20180112142120 (the one that says "SSE4.1"). It seems that the slowdown appears with every Direct3D plugin, even the old ones, in fullscreen mode.

I tried messing with audio configuration and no change.

The older windows 10 update does not have problems with pcsx2 It's the latest update. My problems is wrost than yours with pcsx2 can't run at all. It's running fine with older windows 10.
CPU : I7 6700 3.4 Ghz
GPU : Gigabyte Geforce GTX 1050 TI
SPU : Realtek High Definition Audio
RAM : 16 GB
Os : Windows 10 64 Bit
Emulator : PCSX2 1.5 
Reply




Users browsing this thread: 1 Guest(s)