Dirge of Cerberus
Hi there,

Been trying to get Dirge of Cerberus running but I'm having problems. I should probably note that I'm completely new to PCSX2 so please explain like I'm 5 otherwise I'm probably going to misunderstand.

I can't get this game to run properly, first problem that seems to appear is choppy FMV (I'm presuming the intro text is FMV), it's kind of cross hatched.

Second problem, in game movie/scripted bits seem to run about about half speed, a fairly constant 30fps along with slowmo sound. Doesn't seem to be like that outside of those sequences though.

Specs: Windows 7 running on

i5 460M
Radeon Mobility HD5650

Not sure if anything else is necessary?

Sponsored links

your cpu might not be fast enough to run this game full speed, for the videos you can press F9 to switch to software mode, they will display better but again the videos in this game need a very fast cpu to run full speed (like the ffx-2 videos)

as for speedups sometimes this game likes to run in software mode better then hardware so you can always try switching when its on a slow scene, if you are using a newer pcsx2 build you can try to enable the mtvu speedhack (look through the pcsx2 options).
while looking up your cpu it I noticed it only has 2 cores so I don't know if that option will even help since it's mostly intended for quad-cores, though sometimes it can help dual-core processors.
It's one of the demanding games this one. Videos only work properly in GSdx software mode. Check Allow 8 bit textures in GSdx to get a nice speed up. Also use this hacked GSdx for this (do NOT use it for any other game):
[Image: newsig.jpg]
Odd that it's so "demanding" no? I'm not seeing more than 20% cpu usage on any core, only half my RAM is being used and it's almost as if the video card isn't being touched as the temperature isn't going up much on it, unlike regular none emulated games. This all running at 1920x1080. I would have expected to see something more measurable on my comp if it was really gobbling up so much?

That "hacked GSdx" seems to have done a good job, the FMVs run fine with it+software mode. Slowdown in game is still there though, unfortunately.
you're only seeing 20% because of the CPU's HT, if you disable that and you will see the real percent, the system sees extra 'cores' (HT) not being used and calculates the value percent based off that, but really your cpu is most likely maxed out.

this game is also heavy on the GS, try native mode if you are using upscaling if for some reason its not the cpu Smile
Native seems to be permanently selected on the hacked GS.

I've been toying with settings for a while trying to see if there's any combinations that cause improvements. For the benefit of others that might find this thread turn on speedhacks and set VU cycle stealing to the first notch on the slider. It causes occasional graphical flickers but absolutely all of the in-game stuff is working at a solid 59fps for me now, no issues whatsoever aside from the occasional flickering graphic, this mostly only happens in the menus though so it actually doesn't affect gameplay much at all.

Any reason why the performance should be so much better with this setting?
Quote:Native seems to be permanently selected on the hacked GS.
Uh not? Maybe you should delete your GSdx.ini
[Image: newsig.jpg]
Oh? That's odd, it's greyed out for me?

Before I change or do anything is there a folder or file I should save to keep all of the settings and whatnot that I've made for the game so far? I'd rather not delete/change anything and find myself unable to replicate it if there's something else I forget I've changed later. It's running extraordinarily better for me, besides the flickers from time to time. The gameplay is at least going at regular speed. FMVs are slightly slower than they should be I believe, there's also some slowdown in the cutscene in-game graphics sections, the actual gameplay however is running at regular speed though which to me is more important. I can grab cutscenes and whatnot off youtube to watch at standard speed.
are you sure you dont have software mode selected in gsdx? that's the only way I know of that would grey it out.

Users browsing this thread: 1 Guest(s)