Dirge of Ceruberus - Final Fantasy 7 can not go through a road while PS2 can
In Chapter 11 of the game,

There is a road at map position "K7", where the road is narrow betwen 2 walls.
The road should l broad enough for Vincent Valentine to go threough on PS2, but not on pcsx2.

I checked wiki, this seems not a known issue.
I tried v1.2.1 and newest git(2015/12/28) version but no luck.
I tried to switch to EE and VU interpreters and the extra clamp modes but no luck.
I use Gsdx OpenGL HW/SW...

My CPU is Intel i7-6700k.
GPU is GTX970.

Any suggestion?

Attached Files Thumbnail(s)

Sponsored links

Please post the full emulog after you observed the problem.

Have you followed a youtube walkthrough? Maybe you missed some key event beforr you can pass?
The log shows nothing special, it's spam of DVD load logs, and I think there is sometimes some EE op error as soon as game start, but no matter it shows or not, the invisible wall exists.

I found a full walkthrough of this game on Youtube, I am sure I got everything I need to pass here.

BTW, I think there are couple of regressions in this game:
1. the invisible wall.
2. the software renderer performance: The walkthrough on Youtube use older CPU than mine, and runs 60FPS constantly in this game. While I get some slow done everywhere, so I use hw renderer for most part of this game.

I want to try the version that video used, but I can not find a usable download link for that revision: 4866 by google.
1. Try testing some older revisions of PCSX2. 1.0.0 for example. To see if the problem exists there as well.

2. Slowdowns in software mode might be related to the Skylake CPU issue that has been popping up, where it only uses 1 thread instead of the amount you entered.

You should post your test results on github if you can when testing 1.2.1 vs the new git builds, it will help the devs. https://github.com/PCSX2/pcsx2/issues/998
AMD Ryzen 5 3600 @ 3.60~4.20 GHz | Corsair Vengeance LPX 16 GB (2x8GB) DDR4-3200
MSI GeForce GTX 1660 Super @ 6 GB | Kingston A400 480GB SSD | Windows 10 Pro x64 (b19043.1288)
Can i please see the completely ordinary emulog that doesnt show anything special? Please run the game until you observed the bug and then just copy paste the content.

Please play with ee clamping precision -> full and different ee rounding modes. Please check some manual game fixes as ee timing hack and whatrver else you see that sounds funny enough.
IIRC this game had problems with round modes...
tried setting it to realistic ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Here is the full log by run it w/o saved state. (EE: full)

PCSX2 1.3.1-20151228220501 - compiled on Dec 28 2015
Savestate version: 0x9a0b0000

Host Machine Init:
Operating System = Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 16344 MB
CPU name = Intel® Core™ i7-6700K CPU @ 4.00GHz
Vendor/Model = GenuineIntel (stepping 03)
CPU speed = 4.006 ghz (8 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 7ffafbbf
x86EFlags = 2c100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins...
Binding GS: G:\pcsx2_newgui\plugins\gsdx32-avx2-r5875.dll
Binding PAD: G:\pcsx2_newgui\plugins\LilyPad.dll
(GameDB) 9693 games on record (loaded in 118ms)
Binding SPU2: G:\pcsx2_newgui\plugins\spu2-x-r5875.dll
Binding CDVD: G:\pcsx2_newgui\plugins\CDVDiso-r5384.dll
Binding USB: G:\pcsx2_newgui\plugins\USBnull-r5403.dll
Binding FW: G:\pcsx2_newgui\plugins\FWnull-r5403.dll
Binding DEV9: G:\pcsx2_newgui\plugins\DEV9null-r5403.dll
Plugins loaded successfully.

HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Init PAD
Init SPU2
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\Users\Chiajung\Downloads\Final Fantasy VII - Dirge of Cerberus [NTSC-J] [SLPM-66271].iso
Image type = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1959840 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0 [File]: G:\pcsx2_newgui\memcards\DCFF7.ps2
McdSlot 1 [File]: G:\pcsx2_newgui\memcards\Mcd002.ps2
McdSlot 2 [File]: [is not memcard file]
McdSlot 3 [File]: [is not memcard file]
McdSlot 4 [File]: [is not memcard file]
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: HK v02.20(20/06/2005) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLPM_662.71;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLPM_662.71;1) Game CRC = 0xAFAC88EF, EntryPoint = 0x00100000
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLPM_662.71;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
Not found Cheats file: G:\pcsx2_newgui\cheats\AFAC88EF.pnach
Overall 0 Cheats loaded
EE: Unrecognized op 1
EE: Unrecognized op 4d504c53

If I load a saved state, there is no EE op errors. These errors shows up right after opening movie before main menu.

I will try older version and report later.

V1.0 has exactly same result in this part... and some enemies appears earlier than new version.
However, I forget which version is closer to the real hardware.

Does plugins affect this issue? I use the same setting and plugins while test v1.0.
Quote:isoFile open ok: C:\Users\Chiajung\Downloads\Final Fantasy VII - Dirge of Cerberus [NTSC-J] [SLPM-66271].iso

Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)