Does anyone else have this problem with GSdx
This may be a bug but someone else have to check too.

Start any game,close the game window by using the X button at the upper right and try to open the GSdx settings.This will result in couple of errors and in the end,you won't be able to continue your game.

The problem don't appear if you open the GSdx settings window while the game window is open or if you close it by using the Esc button(it happens only if you close the window by using the X button).

I'm using pcsx2-r5199 but this problem is not something new(at least for me)

Sponsored links

haved you try use "Resume" during emulation and the game window was intentionally closed
Main PC1:i5-4670,HD7770(Active!)
Main PC2:i5-11600K,GTX1660Ti(Active!)
PCSX2 Discord server IGN:smartstrike
PCSX2 version uses:Custom compiled build 1.7.0 64-bit(to be update regularly)
smartstk's YouTube Channel
You can continue the game if you close the game window by using Esc or the X button but if you try to open the GSdx settings first when you closed the game window by using the X button,you're doomed.
Oh yea, the "couple of errors" are the problem. Since the plugin gets messed up, so it will then refuse to open. Something weird happens when closed by X.
[Image: nbKSK.jpg]
First I get "GS plugin failed to open...."
If I press Cancel,I'll get "Warning! System plugin have not been loaded. PCSX2 may be inoperable"
If I hit ok,the plugin selector window will open and if I try to continue the game(resume),I'll get "Invalid Window handle passed to LilyPad" and that's all,I can't continue the game
It's probably another thread state problem which is a pain to work around.
Jake worked a lot on issues like these and the remaining ones are simply too complicated to fix.
Just avoid doing things this way, okay? Tongue2
I'm just glad I'm not the only one who's ran into this. lol
nah, I run into the same thing too! lol
and now I'm glad I'm not the only one too!
but my game keep slowing down. like playing in slow motion, sigh.
just don't use the X then, problem solved.
I use my mouse for almost everything and I rarely use the keyboard for anything other than typing.
And btw,it doesn't happen only if you click on the X ,it also happens of you right click on the task in the taskbar and use the Close menu(probably this is doing the same thing as closing the window by clicking on the X button)

Is the option in LilyPad actually work "Send Escape on window close"...the way I understand it,this should fix the problem but it's not(only pressing Esc to close the window don't invoke this problem)

BTW I doubt this will be of any use but the problem is gone on the newest beta of the OLD gui(pcsx2-r2186)even with the newest plugins

Users browsing this thread: 1 Guest(s)