Dot Hack GU 1 + 2 (possibly 3) issue
First for ease of help my specs I am using
CPU : i5 4690k
Ram : 8GB
GPU : GT 640 ver. 2 (1GB GDDR5 variant equivalent to the GDDR5 730 just far less common)
PCSX2 version : 1.4.0 stable Standard plugins in the 1.4.0 release
GSDX plugin used : all of them
default settings: safe (2) used unless testing fixes

Dot hack G.U. 1
Dot hack G.U. 2
Probably G.U. 3

Alkaid's outfit, well really the bottom of her "cape?", decides that it is bored of following the rules of physics and decides to dance.

Extra info/ attempts at "fixes"
I decided to play through all of the G.U. series to do an update on the current state of it for the PCSX2 compatibility wiki since the last official update was for 1.1.0 and I personally love this series.  I also wanted to see if there were any issues and try and find workarounds for them if possible.  

Dot hack G.U. 1
The only issue I had besides Alkaid was some issues with the FMVs looking like they had been placed on top of green "screen" rectangles.  Software mode fixed that and looking on this site showed me how to add automatic software mode during FMVs to the preset list for the game.  This is nice since I am trying to avoid having to have people have to change too many presets if it can be avoided.  In this volume Alkaid shows up very little and while it is kinda annoying in the few cutscenes she is in it was not too bad due to limited Alkaid in general.  Also the half pixel offset gets rid of 80-90% of the ghosting effect with an occasional HW/SW/HW refresh fixing the rest and some of the garbage on the sides if you don't use a 101% zoom

Dot hack G.U. 2
I was kinda hoping that the slightly modified game engine in vol 2 might make a difference.... no.  I am now at the part where Alkaid joins the party so I could easily do testing and have been trying various "solutions" to no avail for 2 weeks

Attempted solutions:
1. Using GSDX everything  -- Tried each type of GSDX in hardware and software (yes I know redundant) and even tried each plugin variant too (SSE2-AVX2)  None fixed the issue.
2.  Tried changing VU1/VU2/Both to SuperVU and tried each combo of Rounding and Clamping (saw it mentioned on the forum)
3. Changed the EE rounding and clamping options
4.  Tried native resolution (was on 2x) and custom resolutions (custom caused more issues then 2x even when set to 2x the native resolution)
5. Tried turning off all speed hacks - Tried turning on MTVU ( i usually keep it off since that was the default way it was)
6. I have tried running from my DVD and remaking the ISO of my DVD just in case (followed a guide making the second iso just in case my way was causing issues)

other notes:
Alkaid's dancing cape happens in almost all cutscenes so far but when she is standing still it only happens when she is at a specific angle (see pics if the upload works)

Any help would be appreciated.  At this point a way to just make that part of her outfit disappear (cheat code or emulator setting) would be a viable thing to me.

Attached Files Thumbnail(s)

Sponsored links

Try the latest git build from the link below, it's possible your issue has already been fixed as we fixed another issue similar quite recently, so give it a go and see if it helps. If it doesn't, try turning the presets off and set the VU and EE clamping to full, if that doesn't work, try playing with the rounding modes for both the EE and VU and see if t hat helps!
[Image: ref-sig-anim.gif]

Currently testing with version : PCSX2 1.5.0-20170421224519 - compiled on Apr 21 2017

EE Clamping : changed nothing at all (during my cutscene and turn the Alkaid in town test)
EE Rounding : Changed very little if anything -- it might have in conjunction with the VU rounding made her cape flap in a different pattern, but not really a fix.

VU Clamping (there is no "full setting so I tested extra and extra +sign) :  Did not fix Alkaid, but did fix a different issue where the black subtitle letterbox in cutscenes will disappear depending on the camera  transition when the focus moves.  Both extra and extra + sign fix this and I will have to test more to see if it changes anything else in game.
VU Rounding : Again Changed very little if anything -- it might have in conjunction with the EE rounding made her cape flap in a different pattern, but not really a fix.

Method of testing:
Tested the game with default settings after importing my in game save and lilypad config.  Between each change of the Clamping/rounding I did a full shutdown of the emulator and the program.  I changed both Clamping to the lowest on on each list and went through and tested each combination of rounding.  Then I changed the VU up one and redid the same tests.  results above.

Is there anything else that might be good to test? Is there any info that I can get you that might help figure out what is going on? Also is it just me or is there a slight overall improvement in the visual quality in the Git build vs the 1.4.0 stable or is this issue just slowly driving me insane?
There is a slight visual quality improvement yes Smile

I think you might have to just live with an unruly cape for now!
[Image: ref-sig-anim.gif]

Ok, thank you for the help.

Also since the VU clamping does fix a minor issue with the cutscene letterbox which should I test the rest of the game with since extra and extra + both fix it. Is one more or less likely to cause any other issues?
You can try it if you like, shouldn't cause any harm Smile
[Image: ref-sig-anim.gif]


Users browsing this thread: 1 Guest(s)