Dragonball Z Budokai Tenkaichi 3 Running too Fast
I've tried everything I've found from other forum posts. I have frame limiting on, and I have the NTSC and PAL framerates set to the correct values. But when I play Dragonball Z Budokai Tenkaichi 3, everything plays way too fast. How do I fix this?

Attached Files Thumbnail(s)

Sponsored links

You sure you didn't simply turned on Turbo(with TAB key)? When you run the game in the window frame limiter does say "normal", or something else?Tongue

That's the most common problem since everyone love to abuse alt+tab, or using wsad and surroundings for keyboard controls and since newbies typically don't know half of the keys accidents can happen. Soo just to make it sure if it doesn't say "Limiter: Normal", keys for you:
- TAB - toggles Turbo mode(shift+TAB would be slowmo, but you have it set at default 50% speed, hence it would just slow down the game;p),
- F4 - toggles frame limiter.
^If you're pressing any of it by accident or worse, set it as a key to controlling game, now you know why the game runs too fast;p.

Other than that, not much could be broken that would make the game run "too fast" unless using some strange hacky pcsx2 build. You could always try to restore default setting. Or maybe it's just your first time playing this game or all your previous times were made on some ancient emu version and/or awful crappy settings? I would say this game feels somewhat faster than most "normal" side view fighting games so might be just your feeling.
I would try that, but something even weirder is happening now... I have the correct iso selected, and then when I go to start it up it gives me some kind of memory card menu in Spanish... I will attach a screenshot. How do I get out of this menu and back into the game?

Attached Files Thumbnail(s)
Update... I got the menu to English, but it seems that the ISO won't boot, it just goes into the PlayStation menu... How do I get the game to boot?
Tried fast boot ~ Boot CDVD (fast)?:3 Full boot like to have some issues at times, in case you used that.
What version you use?
Use latest svn cos in your screenshoot there still option "disable gs output" in latest svn that option has been removed.
Are you sure you didn't press the frame limiting enable/disable and are you sure you didn't do turbo mode?
Specs: Intel Pentium P5 @ 60 Mhz, 1 Gigabyte HDD, OS: DOS
Only use pcsx2 1.0.0 with default settings it works....

And do not use any speed hacks

Users browsing this thread: 1 Guest(s)