Dualshock 2 Controller with USB Adapter - Some Buttons Not Working
Hey everyone,

Having used PCSX2 for some time now, I decided to switch out the Xbox 360 controller I regularly used for a Dualshock 2 controller in pursuit of a more 'authentic' experience playing through the Playstation 2 games catalogue. I managed to find my old Dualshock 2 controller, and was in luck to find an affordable adapter on Amazon to give it a shot as my primary PCSX2 gamepad (running on a Windows PC).

I connected the adapter, plugged it in, let Windows find the generic USB driver, and fortunately after loading up PCSX2 it was detected by Lilypad as a 'DX USB Gamepad'. I highlighted the entry and hit the 'Test Device' button to see that everything was in order, but found that only the analog sticks, start button, select button and analog button were being registered. Neither the D-pad, shoulder buttons or the shaped buttons to the right of the controller were being detected. I also attempted to bind them, but found the aforementioned buttons were not being registered there either.

I've looked around and have struggled to find any similar forum posts, so I'm wondering if anyone has attempted something similar and perhaps found a workaround to this issue? The adapter to turn the Dualshock 2 controller into a USB device was a generic adapter that didn't come with any drivers, so I have had to rely on the default Windows driver for it. Based on this, I am relatively sure that the adapter isn't faulty, as it did detect input.

Would really appreciate if anyone with experience on this matter could chime in with their input. Thanks!


UPDATE: I have just tried using the same adapter with my other Dualshock 2 controller and have found that it works, so I guess the fault was with the first controller I tried. Thread can be locked/archived now.

Sponsored links

Users browsing this thread: 1 Guest(s)