Poll: Do you rock?
You do not have permission to vote in this poll.
2 100.00%
0 0%
Total 2 vote(s) 100%
* You voted for this item. [Show Results]

Dualshock 3 Vibration Issues
Hey all,

Let me give you a quick rundown:

- Using Dualshock 3
- Using bluetooth
- Using latest MotioninJoy
- Using latest PCSX2
- Using latest Lilypad plugin
- Controller works fine (in game, every button and joystick works)
- Vibration works in MotioninJoy "test vibration" (yes, through the bluetooth)

No matter what I do though, I can't get vibration to work in PCSX2 (or ePSXe for that matter). I've messed with the LilyPad settings as much as I can, but still no luck. Any help (like some screenshots of someone's lilypad and motioninjoy settings)? If you need more info, please let me know and I'll reply. THANKS!!

Sponsored links

Are you using the XBOX360 pad profile in Lilypad?
(04-08-2011, 12:00 AM)rama Wrote: Are you using the XBOX360 pad profile in Lilypad?

I attached screenshots of my settings. I tried using all three different Keyboard APIs, I tried only using one of the "big motor" and "small motor" settings, then I tried adding them all. I unchecked the "Xinput" and still nothing. It's a bit frustrating that I have everything except the vibration working. Any help would be really appreciated. Thanks all!


the motionjoy driver defaults to common class rumble rather than dinput force feedback.
(04-09-2011, 04:20 AM)Squall Leonhart Wrote: the motionjoy driver defaults to common class rumble rather than dinput force feedback.

so that means.....? How do I fix this?
Well, I have rumble working here by using the 360 emulation option in MotioninJoy and 360 pad input in Lilypad.
No Bluetooth though.
amazing, it works perfectly on 360 mode in motioninjoy and lilypad, with the bluetooth and everything. thanks for the recommendation!
Sorry to bring this thread back up but here is a way to make it work without 360 emulation.
I am currently using this method and it works perfectly with PCSX2.


if the link above is not allowed-

(Note that the in the link, he has an attached file that you may need)
By: Andreotti
Over at Motioninjoy forum

Hi, I have recently downloaded Motioninjoy and noticed that my 32-bit application (epsxe)
wont use vibration when i am running windows 7 x64 ultimate edition, i found a way to fix
my problem so i thought i would share it here and maybe it can help others.

My Setup:

Operating System = Windows 7 x64 Ultimate
Motioninjoy = Version 0.6.0003(signature)
Application = ePSXe Emulator 1.7.0
Controller = PlayStation 3, Dualshock 3, (Original)

To make ePSXe use the vibration feature of the PS3 controller i needed to register the 32-bit MijFrc.dll,
the 64-bit MijFrc.dll is already registered when i installed Motioninjoy x64 and loaded the drivers.

note: quotes are to define full file names,directorys or commands

1. Have Motioninjoy Version 0.6.0003(signature) 64-bit Installed

2. Download The Rar File I Have Attached (Taken From Motioninjoy Version 0.6.0003 signature 32-bit)

3. Extract The "MijFrc.dll" From The Rar File You Just Downloaded And Place It In Your "C:\Windows\SysWOW64" Folder.

4. Click Button Start And Type "cmd" And Press "Enter" To Open A Command Prompt.

5. Type This Command Into The Command Prompt, "regsvr32 C:\Windows\SysWOW64\MijFrc.dll"

To check the MijFrc.dll registered ok, open up dxdiag by clicking the start button and typing "dxdiag" and press "enter"
at the top click the "input" tab, (make sure your ps3 controller is connected) and look for
Device "Motioninjoy Virtual Game Controller" (should be at the bottom) then look to the right under
Force Feedback Driver and it should say "C:\windows\syswow64\mijfrc.dll"

note: Dont worry About The First Device "Motioninjoy Virtual Game Controller" Not Showing The MijFrc.dll, this is ok.

Thats It, Vibration should now work for 32-bit applications or at least ePSXE, all i can say is my 32-bit epsxe would not use vibration (although 64-bit motioninjoy could use it)
and after completing the steps above most of the ps1 games that i play on epsxe now have vibration on the ps3 controller

This Works Also Through USB And Bluetooth.
If You Need Help Just Ask.

Hope This Helps
I know this thread is 4 years old but I am encountering this problem.
Can anyone upload MijFrc.dll for me? The link is gone.
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)